Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Help please advice on the issue.

Normal load on the cpu 20-30% us + sy. After restoring the database files from the slave server (same version) began a periodic problem. mysql starts to load the cpu at 100% (us + sy grows proportionally). The queue is growing, everything slows down. But with mysqladmin flush-tables are normalized for a few hours.

Dedicated linux server running mysql 2 x E5506 24Gb RAM, database size 50Gb.

[OK] Currently running supported MySQL version 5.0.51a-24 + lenny4-log
[OK] Operating on 64-bit architecture

-------- Storage Engine Statistics --------------------------------------- ----
[-] Status: + Archive-BDB-Federated + InnoDB-ISAM-NDBCluster
[-] Data in MyISAM tables: 33G (Tables: 1474)
[-] Data in InnoDB tables: 1G (Tables: 4)
[-] Data in MEMORY tables: 120K (Tables: 3)

[-] Reads / Writes: 91% / 9%
[-] Total buffers: 12.8M per thread and 7.1G global
[OK] Maximum possible memory usage: 15.8G (66% of installed RAM)

4000 - 5500 rps

key_buffer              = 1536M
max_allowed_packet      = 2M
table_cache             = 4096
sort_buffer_size        = 409584
read_buffer_size        = 128K
read_rnd_buffer_size    = 8M
myisam_sort_buffer_size = 64M
thread_cache_size       = 500
query_cache_size        = 100M
thread_concurrency      = 24

max_connections         = 700
tmp_table_size          = 4096M
join_buffer_size        = 4M
max_heap_table_size     = 4096M
query_cache_limit       = 1M

low_priority_updates    = 1
concurrent_insert       = 2

wait_timeout            = 30

server-id               = 1
log_bin                = /var/log/mysql/mysql-bin.log
expire_logs_days        = 10
max_binlog_size         = 100M

innodb_buffer_pool_size = 1536M
innodb_log_buffer_size = 4M
innodb_flush_log_at_trx_commit = 2

How to solve the problem?

share|improve this question

2 Answers 2

I think you'll need to narrow down what is happening a bit more before you can get good answers. I'd start turning on the slow query log to see if it's caused by any specific queries, and maybe run mysqlcheck as a sanity test.

share|improve this answer
    
There are no specific queries. mysqlcheck report OK –  mirage Nov 14 '11 at 11:07

Do you tried to perform a sync from the slave to the master? (should not work) or a dump of the slave restored on the master?

share|improve this answer
    
I've copied /var/lib/mysql and removed master.info –  mirage Nov 13 '11 at 16:59
    
Ok, you should try a dump with the correct options then ;-) –  Dr I Nov 14 '11 at 12:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.