Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

By default, when a Polycom VoIP phone has a voicemail message waiting, it both lights the MWI light, and plays a sound every several minutes. I've never met a more self-important feature in a phone, ever.

How can I make that sound go away, forever?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Add this to the XML config you pass to the phone. (I've only tested this with firmware 3.1 and higher.)

<MESSAGE_WAITING 
    se.pat.misc.messageWaiting.inst.1.type="silence" se.pat.misc.messageWaiting.inst.1.value="0" 
    se.pat.misc.messageWaiting.inst.2.type="silence" se.pat.misc.messageWaiting.inst.2.value="0"
    se.pat.misc.messageWaiting.inst.3.type="silence" se.pat.misc.messageWaiting.inst.3.value="0"
    se.pat.misc.messageWaiting.inst.4.type="silence" se.pat.misc.messageWaiting.inst.4.value="0"
/>

The sound you hear is actually a four-note tune. You have to turn all four notes to silence to completely disable audible MWI.

share|improve this answer
    
maybe you could mark your answer as accepted? –  BGM May 24 '12 at 14:16

You can change it for all your phones by making the change in your sip.cfg file. I have a sip_318.cfg and a sip_326.cfg - one for my ip601's and one for my ip430's. If you make his changes, you can disable the sounds. I found the noise to be annoying, too, so I added Jeremy's edits too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.