Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm in the middle of setting up an Exchange 2010 Server. Currently, we use a SaaS provider for Exchange 2007 services. Some (but not all) of my users have been reporting that they are receiving Outlook/Exchange login prompts to login to the new Exchange server. This is happening without any intervention on the client's machines. The Exchange server is a member of the domain and connects to the domain site remotely through a site-to-site VPN. What can I do to prevent these login prompts from appearing? Will shutting down the new server until it is time to switch resolve these issues?

A little more info: I found that on one of the client computers, all of the settings for Outlook over HTTP had been changed (automatically) from webmail.provider.com to mail.company.com (the latter being the new server). This happened when I enabled Outlook Anywhere access on Exchange 2010. I changed the client's settings back, and everything was groovy. But, when I disabled Outlook Anywhere again, the logon prompt came back.

share|improve this question

1 Answer 1

up vote 6 down vote accepted

When Outlook starts up it looks for the Exchange SCP (service connection point) in AD which directs Outlook to the Autodiscover URL of the Exchange Server, which stores the Exchange client access settings in the Autodiscover.xml file. That's why Outlook automatically configures itself to connect to the internal Exchange server. I dealt with this during an SBS migration while we staged and scheduled the transition from an external email provider to Exchange, with the Exchange migration occurring after the migration from SBS 2003 to SBS 2007. Here's how we dealt with it:

We configured the MSExchangeAutodiscoverAppPool application pool on the Exchange server to not start automatically. The MSExchangeAutodiscoverAppPool application pool is used by the Autodiscover virtual directory on the Exchange server to perform the functions listed above (Outlook automatic configuration). With the application pool stopped, you're essentially disabling Autodiscover. You can re-enable it when you're ready by setting the application pool back to automatic startup.

http://technet.microsoft.com/en-us/library/bb124251.aspx

http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html

share|improve this answer
    
This worked! Thanks. –  tacos_tacos_tacos Nov 14 '11 at 20:59
    
Glad to help. It's a hack but it does the job. –  joeqwerty Nov 15 '11 at 0:17
    
Joe - thanks from me, just put this into effect at a place that is transitioning through a cross-forest migration from Exch 2007 to 2013, without actual co-existence. The target mailboxes are live but slowly being migrated to via 3rd-party tools, and the workstations in the new domain keep trying to connect to them instead of the old ones. Messes everyone up after morning login. –  mfinni Jun 6 '13 at 19:58
    
Glad it helped. There are probably a number of other methods, some probably better, but this worked for me so I use it when I need to. –  joeqwerty Jun 6 '13 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.