Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install VMWare tools on a Fedora 10 guest (Windows Vista host) and running into problems. I am logged in as root. Upon attempting to install, I get a message saying "Guest operating system has locked CD-ROM...). Various forums recommend overriding this message so I did so but the system simply hangs. Anyhow, went to VMWare help (http://www.vmware.com/support/ws55/doc/ws_newguest_tools_linux.html) on this subject. In attempting to understand/resolve this mounting problem, I tried mount /dev/cdrom /mnt/cdrom upon which I get a message saying "block device /dev/sr0 is write protected mounting read only". Not sure if this is the cause of the problem. But now I am stuck and confused. Can anyone enlighten me on what all this means and how I can resolve this installation problem? Thanks much.

Just adding new details: I have to be in text mode to install the tools. So, I did so. Logged in as root, did the umount. STILL get the cd locked message, override, and start getting a slew of SQUASHFS errors upon which things hang. If I try and quit the install do an ls (for example), I get input/output errors reported.

As suggested by someone, I downloaded open-vm-tools but when I do a ./configure, there is a whole slew of missing libraries I have been patiently trying to install (yum update hangs). yum install gcc glib2-devel pam-* xorg-x11-* libX* uriparser* libpng* gtk+-devel. Now when I get to install gtk2-devel, I get a rpmdb bus error and all is shot. So, I install gcc-c++ (yes I am pulling threads now) and re-try. Now it does a successful transaction test, starts transaction and hangs. I am so far in that I don't want to give up, but I am at a loss as to what I need to be doing here because I cannot believe this install could be this convoluted (or is it?)

share|improve this question

4 Answers 4

May I suggest trying open-vm-tools? I've actually found them to be better than VMwares proprietary tools in most cases.

share|improve this answer

The message "block device /dev/sr0 is write protected mounting read only" is normal, it means that you can't write files on your CD-ROM with the current media.

share|improve this answer
    
pauska, So this is not related to the CD-ROM locked message then? I suppose mounting the image to the virtual cdrom is not exactly the same as writing. However, it would appear that the umount should at least prevent that message. The input/output errors upon continuing I'm just not sure of. Am trying to figure out if I can load this image manually to some location. Just not sure how to do this from within the vmware guest. –  user10510 Jun 29 '09 at 12:20
    
No, it's not related. I get the same message every time I mount a ISO-image/media/VMware tools on my VMware esx servers. Sorry if it's not helping you, but I thought you should know that the read-only message is normal. –  pauska Jun 29 '09 at 13:54

It sounds like your Fedora 10 guest already has the CD-ROM mounted when you're trying to install the tools. Try this:

  • Boot the guest normally.
  • Logon as root and run the command "umount /dev/cdrom".
  • In the VMware menu, attempt the guest installation.

Step 2 insures tht the CD-ROM isn't mounted and, as such, VMware should have no problem "inserting" the VMware tools ISO into the virtual CD-ROM.

share|improve this answer
    
Hi tried this but no luck. I still get the "guest has locked.." message when trying to install vmware tools. Moreover when I override and continue, I get input/output errors reported when trying to run various utilities. For example, if I do an ls from the terminal or try and display the system log. –  user10510 Jun 29 '09 at 3:36
    
Not progress but some new information. I realized I have to be in text mode to install the tools. So, I did so. Logged in as root, did the umount. STILL get the cd locked message, override, and start getting a slew of SQUASHFS errors upon which things hang. –  user10510 Jun 29 '09 at 4:06

Cancel the vmtools install from vmware(if it didn't do it automatically), do a: umount /dev/cdrom, disconnect any cdroms you have attached to the guest OS, and then retry the vmtools install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.