Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Ubuntu server. I am trying to install Vsftpd but it shows this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package vsftpd

After that, I checked the Internet connection by ping, which worked fine.

I tried to apt-get update but it was not possible it shows:

Err lucid Release.gpg
Temporary failure resolving ''
share|improve this question

if you can ping, but can't ping it can be a problem with dns server. Try to ping

share|improve this answer
I find out that my server can ping by IP address but cant ping by domain. For example I can`t ping but I can ping – user963587 Nov 15 '11 at 5:20
I went to /etc/apt/sources.list and changed all "" to and apt-get update worked. – user963587 Nov 15 '11 at 5:35

As root, edit /etc/apt/sources.list, replacing with another mirror. Run apt-get update to fetch the new mirror's package list, then apt-get install vsftpd.

share|improve this answer

It sounds like there's something wrong with your DNS setup. Have a look in /etc/resolv.conf. There should be one or more lines in there that look like this:


If there are no nameserver lines, then add those two. They are provided by Google and are free to use.

If there are nameserver lines, test that they are working.

You can test if DNS is working with the dig tool. Use dig to test your current setup. use dig @ to test a particular name server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.