Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Im running Cherokee as a reverse proxy to a server running a php web application and am getting lots of 502 and 504 errors.

The issues seems to only happen with image uploads but is not tied to a specific image or size. It has happened with images of 100kb while other images of 1.5mb would upload fine. There does not seem to be a reliable way to reproduce this issue, its pretty random.

The web server is currently running Apache, but it was doing the same thing before when it was running Cherokee also.

The reverse proxy is sending requests to various different Apache web servers and seems to be happening on all of them.

This is about all the data I have related to the issue. Let me know if there is any more info required.

Any help is appreciated, thanks.

time-out chart for 1 week

EDIT: more info

Cherokee on the reverse proxy is 1.2.101 ubuntu on the reverse proxy is 10.10, Linux reverse-proxy-a 2.6.35-30-virtual #61-Ubuntu SMP Tue Oct 11 17:34:26 UTC 2011 i686 GNU/Linux

apache2 on the application server is 2.2.16 10.10, Linux v2-demo 2.6.35-30-virtual #61-Ubuntu SMP Tue Oct 11 17:34:26 UTC 2011 i686 GNU/Linux

A lot of the time there is no actual error and the page just 'hangs'. The little loading icon in the browser spins but nothing happens. while this is going on looking at htop on both servers there is absolutely nothing going on. The page will stay 'loading' like this until its stopped.

EDIT 2: Cherokee has now been spitting out errors like below (a bunch of them exactly the same just different times):

{'type': "warning", 'time': "14/11/2011 10:58:36.133", 'title': "Taking source='<host>:80' back on-line", 'code': "balancer_round_robin.c:82", 'error': "62", 'description': "The information source is being re-enabled.", 'version': "1.2.101", 'compilation_date': "Oct 19 2011 11:46:03", 'configure_args': " '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--libexecdir=${prefix}/lib/cherokee' '--disable-maintainer-mode' '--disable-dependency-tracking' '--host=i686-linux-gnu' '--build=i686-linux-gnu' '--enable-os-string=Ubuntu' '--prefix=/usr' '--localstatedir=/var' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--docdir=/usr/share/doc/cherokee-doc' '--with-wwwroot=/var/www' '--enable-pthread' 'build_alias=i686-linux-gnu' 'host_alias=i686-linux-gnu' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--libexecdir=${prefix}/lib/cherokee' '--disable-maintainer-mode' '--disable-dependency-tracking' '--host=i686-linux-gnu' '--build=i686-linux-gnu' '--enable-os-string=Ubuntu' '--prefix=/usr' '--localstatedir=/var' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--docdir=/usr/share/doc/cherokee-doc' '--with-wwwroot=/var/www' '--enable-pthread' 'build_alias=i686-linux-gnu' 'host_alias=i686-linux-gnu' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS='", 'backtrace': ""}
{'type': "warning", 'time': "14/11/2011 10:58:52.332", 'title': "Taking source='<host>:80' back on-line", 'code': "balancer_round_robin.c:170", 'error': "63", 'description': "The information source is being disabled.", 'version': "1.2.101", 'compilation_date': "Oct 19 2011 11:46:03", 'configure_args': " '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--libexecdir=${prefix}/lib/cherokee' '--disable-maintainer-mode' '--disable-dependency-tracking' '--host=i686-linux-gnu' '--build=i686-linux-gnu' '--enable-os-string=Ubuntu' '--prefix=/usr' '--localstatedir=/var' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--docdir=/usr/share/doc/cherokee-doc' '--with-wwwroot=/var/www' '--enable-pthread' 'build_alias=i686-linux-gnu' 'host_alias=i686-linux-gnu' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--libexecdir=${prefix}/lib/cherokee' '--disable-maintainer-mode' '--disable-dependency-tracking' '--host=i686-linux-gnu' '--build=i686-linux-gnu' '--enable-os-string=Ubuntu' '--prefix=/usr' '--localstatedir=/var' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--docdir=/usr/share/doc/cherokee-doc' '--with-wwwroot=/var/www' '--enable-pthread' 'build_alias=i686-linux-gnu' 'host_alias=i686-linux-gnu' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS='", 'backtrace': ""}
{'type': "warning", 'time': "14/11/2011 11:00:38.588", 'title': "Sources exhausted: re-enabling one.", 'code': "balancer_round_robin.c:122", 'error': "64", 'description': "All the Information Sources have been off-lined. The server needs to re-enable at least one of them.", 'version': "1.2.101", 'compilation_date': "Oct 19 2011 11:46:03", 'configure_args': " '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--libexecdir=${prefix}/lib/cherokee' '--disable-maintainer-mode' '--disable-dependency-tracking' '--host=i686-linux-gnu' '--build=i686-linux-gnu' '--enable-os-string=Ubuntu' '--prefix=/usr' '--localstatedir=/var' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--docdir=/usr/share/doc/cherokee-doc' '--with-wwwroot=/var/www' '--enable-pthread' 'build_alias=i686-linux-gnu' 'host_alias=i686-linux-gnu' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--libexecdir=${prefix}/lib/cherokee' '--disable-maintainer-mode' '--disable-dependency-tracking' '--host=i686-linux-gnu' '--build=i686-linux-gnu' '--enable-os-string=Ubuntu' '--prefix=/usr' '--localstatedir=/var' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc' '--docdir=/usr/share/doc/cherokee-doc' '--with-wwwroot=/var/www' '--enable-pthread' 'build_alias=i686-linux-gnu' 'host_alias=i686-linux-gnu' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS='", 'backtrace': ""}

I have now added more vhosts on the apache server that are listening on different ports but serving up the same content. so far this has seemed to help but not 100% sure as its not a reproducible issue

share|improve this question
    
Have you looked in the relevant log files on both systems when this happens ? Can you post as an edit to your question relevant portions of the error logs for us to see please ? –  Iain Nov 14 '11 at 11:38
    
Added some new info, thanks –  dogmatic69 Nov 14 '11 at 12:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.