Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently tried to add a file share on wwwroot to easily be able to deply some files from a different copmuter on the network. I added the share with full access to my user, but only me. After I had copied over the files, I removed the share, but now the web sites does not work propelry anymore. I get unauthirized-messages when I try to access the web pages. It is set up with anonomous access enabled in IIS, and security on folder is set up with read/execute access for Everybody, but it still does not work properly. I tried to remove and add each application under wwwroot in IIS, and that worked for some, but not all.

Any Idea how to fix this?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Add the user "network service" back into the permission set. This is a service account and not a member of the Everyone group. By default IIS runs under the Network Service account unless you manually change the user under the Application Pool setting.

share|improve this answer
    
I found out a fix for it. The anonymous user was set up to be IUSR, and I changed it to use the application pool user instead (which is "Network Service" as you say) . I don't know why this was so, or even why it works now, but it works, so hurray!.. –  awe Nov 14 '11 at 12:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.