Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have read a bunch of posts and other information on the internet and I have yet to come across the solution to this question. On a windows network, all the computers sync up with the domain controller (for time), and this is working. The problem is our domain controller (windows server 2008) has the wrong time. Apparently it is supposed to sync itself with some internet time, although I cannot find the options for setting this up in the normal date/time settings in the control panel.
I think that maybe the domain controller syncs the time with the internet every time it reboots, but it has been a while since the last reboot and the time is a few minutes different from international standard time. I would like to have something similar to ntp (apt-get install ntp) in ubuntu server. This works great ~ it adjusts the server time to the internet time every few minutes.

Thanks for any info.

share|improve this question

migrated from stackoverflow.com Nov 14 '11 at 10:58

This question came from our site for professional and enthusiast programmers.

4 Answers 4

So I found a way to do this that is working, although it is a Third party program that periodically checks an NTP and adjusts the system time. It is a Source Forge project called NetTime -> http://www.timesynctool.com/.

We configured it as a Windows service so it starts a boot up.

share|improve this answer

This is link to a good artice I found on VMware's site.

Follow the steps and you should end up with a server that updates from an NTP server every 15 minutes. It solved my issues.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1318

share|improve this answer

I've successfully used this sequence of commands to configure the time service on a stubborn domain controller. This should only be used on the server with the PDC role, other servers should sync their time from the PDC.

C:\> net stop w32time
C:\> w32tm /unregister
C:\> w32tm /register
C:\> net start w32time
C:\> w32tm /config /syncfromflags:MANUAL /manualpeerlist:us.pool.ntp.org /update

When you want to use a public NTP server, set the syncfromflags to MANUAL. When you want to sync against other servers in the domain, use DOMHIER.

http://technet.microsoft.com/en-us/library/cc773263(WS.10).aspx

share|improve this answer

You probably want net time /setsnmp:..., or you can go to the clock control panel (e.g. right click on the clock in the task bar) and go to the 'Internet Time' tab.

I think you need to edit the registry to alter the update frequency, though:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\Config\UpdateInterval

which is the value in seconds. Google says you'll need to restart the w32time service (Windows Time) to pick up the changes.

share|improve this answer
    
Yeah, one of the problems is that when I right-click the clock on the server, there is no "internet time" option. So, I am not sure how I tell the server to use the internet time. I also saw that on the MSDN sites –  jeffery_the_wind Nov 14 '11 at 16:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.