Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have install the "mysql-6.0.11-alpha-win32" setup in windows 7 . then try to connect to the mysql but it takes long time to connect to the mysql server then show the error message like

--------------------------- 
SQLyog - Free MySQL GUI 
--------------------------- 
Error No. 2003 
Can't connect to MySQL server on 'localhost' (10060) 
--------------------------- 
OK Help 
--------------------------- 

any one have idea about this error no. 2003 then help me.... thanks in advance... .

share|improve this question

migrated from stackoverflow.com Nov 14 '11 at 13:12

This question came from our site for professional and enthusiast programmers.

3 Answers 3

Read this FAQ: http://webyog.com/faq/content/23/15/en/error-no-2003-can_t-connect.html Also this: http://dev.mysql.com/doc/refman/5.5/en/can-not-connect-to-server.html

Note that this is a connection error and not an authentication error (ie: not because user or password is wrong).

First you should check for firewall issues and settings in server configurations like 'skip_networking' and 'bind_address'.

share|improve this answer
    
in the first reference of the link mentioned as comment the "skip-networking" in my.cnf file but in my installation .cnf file "skip-networking" setting not found –  user847455 Nov 14 '11 at 7:40

This is the firewall issue and you need to update the firewall present in the system. Normally Microsoft windows firewall restricts the system to access the permission of the server and it doesn’t allow connecting the server. Then for solving this kind of issue normally we need to update this firewall. The updated version of the firewall will provide this facility to connect the MYSQL Server to the system. Then you can able to run SQL on your system.

share|improve this answer
    
how to update the firewall –  user847455 Nov 14 '11 at 6:57
    
in my system windows firewall is turn off –  user847455 Nov 14 '11 at 7:41
    
Try to update the firewall and try again. if u still got the error msg, try reinstalling it. –  Showket Nov 14 '11 at 8:23

Add mysqlid.exe into your windows firewall settings to access your server remotely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.