Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm wondering if anyone has seen this before, and could perhaps shed some light on a solution.

I'm running Red Hat Enterprise Linux 6.1, fully updated in a text-only server configuration, and the kacpid and kacpi_notify processes have started to take up ~70% and ~15% of CPU time, respectively. I've traced the problem to what looks like an insane amount of ACPI interrupts:

[root@centauri ~]# cat /proc/interrupts | grep acpi; sleep 5; cat /proc/interrupts | grep acpi
  9:     447753          0   32693472          0   IO-APIC-fasteoi   acpi
  9:     447753          0   32850749          0   IO-APIC-fasteoi   acpi

At over 30k interrupts a second, something is clearly wrong. Additionally, if I check another server with a very similar hardware configuration, the interrupt counts for this particular interrupt is always zero. Both systems are running Core i7 2600K processors with hyper-threading disabled. I've tried resetting all defaults in the BIOS, with no luck.

Any ideas what could cause such a high number of interrupts?

If I boot with acpi=off, this problem goes away. Besides power control, are there any drawbacks to running the system with ACPI disabled?

share|improve this question

migrated from stackoverflow.com Nov 14 '11 at 20:07

This question came from our site for professional and enthusiast programmers.

    
Same firmware/BIOS version on both machines? –  James Nov 15 '11 at 1:51
    
Not exactly. The two machines use different motherboard models (both Intel), so its not exactly the same BIOS. I did update the BIOS on the affected machine, with no change. –  Justin Holewinski Nov 15 '11 at 17:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.