Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have JBoss 5 deployed on Solaris 10 - the servers connection has unrestricted high ports (>1023) open to the internet.

I can access the box via ssh & FTP from a second server on the same subnet and anywhere over the internet.

JBoss is running over port 8080 and is accessible via http://locahost:8080 on the box itself. I cannot access it via from either the other server on the same subnet or via the internet.

Is there any service or configuration within JBoss or elsewhere on Solaris 10 that needs to be changed from default to allow http traffic to be served?

share|improve this question
up vote 2 down vote accepted

Start JBoss binding to all IP addresses. -b
share|improve this answer
Great Stuff, works a treat...thanks!! – kgbolger Nov 15 '11 at 22:41
So I’m trying to start JBoss with the bind argument but want it to run in the background so it staying running after I kill the ssh session. I’ve tried setting the ‘LAUNCH_JBOSS_IN_BACKGROUND’ environment variable to 1 before running ./ but the process stays in the foreground, any ideas? – kgbolger Nov 15 '11 at 22:49

Found this in another serverfault thread & it seems to work: To get it to run after you exit: Start it with nohup, end it with &

I ran it as nohup ./ -b &.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.