Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having problems with my SSH client on Ubuntu 10.10.

When I switch on my computer and open a Terminal and execute the command ssh user@host, it gives me a password prompt after which I enter the right password, I then get a prompt to execute my commands on the remote computer.

Now the problem is, after a little while (probably around 10 minutes), the terminal window stops accepting commands (No matter what I type, nothing shows). Once this happens, I close the Terminal window and try to start all over again by opening another Terminal window. But this time around, after entering the right password, I don't get a welcome message or prompt. The cursor just keeps blinking on a new line.

I ran the ssh command with -v parameter and the message I get after a successful login is:

debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_GB.utf8

Still the cursor keeps blinking on a new line without a prompt.

However, Putty SSH client works perfectly on the same machine.

share|improve this question
    
The fact that your connection fails after a few minutes It almost sounds like some kind of NAT timeout between you an the remote host. Maybe specify ServerAliveInterval 60 in your ssh client configuration file. The inability to reconnect, seems like some kind of connection rate-limiting. –  Zoredache Nov 16 '11 at 3:12
add comment

2 Answers

I experienced the same issue, though it was not an ssh issue - when logging on locally to the machine the same thing occurred: successful logon with the 'last logon' message displayed, and then a blinking cursor but no prompt/activity. Through trial and error I was able to resolve the same problem as follows:

  1. Log on as root (another user with sudo privileges should also work, so long as it is not the user experiencing the problem)
  2. Go to the users home directory # /home/user/
  3. Look for a symbolic link file with .LOCKED appended to it. In my case this link pointed to a pid which didn't exist. Delete this link.
  4. Log out

After doing this both my local and ssh logins resulted in prompt being displayed correctly. As a side note I'm using zsh as my shell. I can't say if this will work for other shells but I suspect that it would.

share|improve this answer
add comment

It could be a DNS issue, try with the setting UseDNS no into your sshd_config (and restart the service)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.