Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The error states:

No mapping between account names and security IDs was done.

This is during an upgrade of 2008 sql server with sp3 to r2. This results in the database engine not being installed :( I have googled and there are so many different variations of this error. Most solutions point to some analysis services stuff but mine is specifically for the database engine.

I don't know where to look to resolve this. This is on a windows 2008 server :(

share|improve this question

3 Answers 3

Oh, today I got the same error after SQL Server Analysis Services upgrade (SP installation). In my case it caused by domain user login stated in role membership but already deleted in domain. Deleting this orphaned account from security settings successfully resolved the problem.

So I thought you can try to do the similar actions for Database Engine service. Try to execute sp_validatelogins procedure (in BOL it described as: "Reports information about Windows users and groups that are mapped to SQL Server principals but no longer exist in the Windows environment"). But do not think that each login returned is not actually in AD - the output really only means there is a SID mismatch/conflict.

Hope it helps you to solve a problem.

share|improve this answer
    
When I run this in management studio it produces 0 records. –  oJM86o Nov 16 '11 at 14:39

Were you doing the installation as a domain user or as a local user? The error leads me to believe that you were using a local account, which wouldn't be able to look up the SIDs accounts used in Windows Authentication during the upgrade. Try re-running the installation as a domain user that's a local admin on the server.

share|improve this answer
    
I did the install as a domain administrator. –  oJM86o Nov 16 '11 at 14:40

Are your SQL Service running as a domain user account? Does temporarly running it as Local System solve this?

share|improve this answer
    
They are running as a network service account. –  oJM86o Nov 16 '11 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.