Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just got a Windows Server 2008 R2 64 bit Virtual Private Server (VPS) and found out that the page file was disabled completely. This give me some memory problems where application quit unexpectedly and so on.

The server got 2GB reserved RAM and 100GB hard drive. I am using the Administrator account (part of the Administrators group) to alter the system.

I tried to enable the page file. Both specific values and system administrated. In all cases the setting is reset back to No Page file after reboot. I even tried manually edit the registry setting the page file. The registry key was also reset back to nothing after reboot.

I am not sure what to call it but I am guessing the VPS host uses a system where they have the "main windows installation" and I have the changes or something like that. At least when I hacked the registry and enabled Windows Updates and updated windows my server crash so much that it could not restart. It had to be reinstalled.

I would really love to have a page file or something that does something similar to avoid the OutOfMemory problems I am encountering and I am hoping experts on Server Fault have ideas how to.

share|improve this question
    
Have you tried asking your provider? –  Zypher Nov 16 '11 at 21:56
    
Their respond is that the Page file is enabled on the mail host and therefore disabled on the VPS's, but that does not really solve the issue. –  Anders Nov 16 '11 at 22:48
    
hmm that makes ... no ... sense... there really isn't much you can do without their blessing though –  Zypher Nov 16 '11 at 22:50
    
That is just sad :( –  Anders Nov 25 '11 at 7:55
add comment

1 Answer 1

I'm using a Virtuozzo VPS and have the same situation.

Short answer: No, you can't have a pagefile (virtual memory).

The reason, according to this Parallels' KB article, is that:

each and every VE uses the pagefile residing on the node – i.e. the whole memory which can be allocated by the VEs can be gotten from the physical memory installed on the node and virtual memory allocated from pagefile

So, basically, you are already using a pagefile, but you have no way to customise it because it's on the node which only your host has access to.

Note: a "VE" is a VPS instance/container/whatever

HOWEVER, depending on the version of Virtuozzo your host is running, you CAN emulate having a pagefile in your container by doing exactly what you did, WITHOUT restarting the container. See this article for reference.

Alternatively, you can do the same from a command line or start-up script with the following:

reg add "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management"  /v PagingFiles  /t REG_MULTI_SZ /d "C:\pagefile.sys 2046 4092" 

I have no idea whether this works or not, but I'm giving it a go right now...

share|improve this answer
    
Okay, it doesn't seem to work at all. –  Gaping Headwound Apr 19 '12 at 16:08
    
+1 answers the question as much as is possible. To clean up the answer you should phase the registry setting as a test that was performed to verify the KB. –  Bernie White Nov 5 '12 at 8:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.