Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using the new AWS GUI for Route 53 to setup my domain records. However, the AWS console won't accept the recommended Google Apps SPF record, v=spf1 include:_spf.google.com ~all (found here).

It keeps giving me an error stating

The record set could not be saved because:
- The Value field contains invalid characters or is in an invalid format.

This happens when saving as SPF and TXT. Any ideas?

share|improve this question

4 Answers 4

up vote 26 down vote accepted

I had to wrap my SPF record in quotation marks for it to work.

"v=spf1 include:_spf.google.com ~all"

share|improve this answer
    
Wow, great catch! –  richardaday Dec 2 '14 at 5:51

It's a new feature for the console. Chances are it's the console part that is rejecting the 'invalid' characters, rather than the underlying system.

I'd try setting it with one of the many tools available for configuring Route 53 and if that doesn't work, contact Amazon

share|improve this answer

My fix was to wrap the record in quotation marks and replace the ~ with a -.

Here is the value that works:

"v=spf1 include:_spf.google.com -all"

share|improve this answer
2  
According to support.google.com/a/answer/178723?hl=en you should use ~all not -all for Google Apps. –  Sean Bannister Apr 15 at 15:06
    
The only reason I replaced the ~ with - was to get Route 53 to accept it, but to my surprise, it was also accepted by Google Apps as valid. –  Jacques Snyman Apr 16 at 6:13

Using doubles you can set that value without raising error messages. It worked fine for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.