Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using Meinberg NTP to sync the time in a VPS. The clock refuses to sync - there's a ~30s shift comparing to other servers. Also ntpq -p is continuously showing zeros for reach, delays and jitters, which means something's wrong...

Actions I've taken which didn't help:

  • Restarted the NTP service using a script that comes with Meinberg NTP
  • Added port 123 for UDP and TCP as an exception port to Windows Firewall
  • Added Meinberk NTP executables as an exception program to Windows Firewall
  • Completely disabled Windows Firewall
  • validated iburst appears after each server listed in the configuration file
  • Restarted the server

The OS is a Windows Server Standard SP2 32bit.

What did I miss?

UPDATE 1

Here's ntpq -p result:

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 voxl-nyc-21.ser .INIT.          16 u    -   64    0    0.000    0.000   0.000
 sola-sea-04.ser .INIT.          16 u    -   64    0    0.000    0.000   0.000
 207.32.191.59   .INIT.          16 u    -   64    0    0.000    0.000   0.000

UPDATE 2
Turns out that in addition to the Windows Firewall, our VPS provider has blocked all UDP communication to our VPS instance. After opening UDP port 123 it worked flawlessly.

share|improve this question
    
How long did you give it? –  David Schwartz Nov 17 '11 at 17:28
    
a few minutes... –  Jonathan Nov 17 '11 at 17:28
    
That's probably not nearly enough time. Check back in an hour or so. –  David Schwartz Nov 17 '11 at 17:32
    
Check to see that the windows NTP server is disabled. May I ask why you are not using the inbuilt windows NTP service? (serverfault.com/questions/199205/sntp-why-do-you-mock-me) –  Ablue Nov 17 '11 at 23:32

1 Answer 1

up vote 4 down vote accepted

Now it seems you're not communicating with your peers. Either they're not up, not reachable, or a firewall or similar device is blocking UDP port 123.

207.32.191.59 appears to be a working stratum 2 server to me, so if the machine otherwise has working Internet access, I'd bet on a firewall.

share|improve this answer
    
David, do you know how I could set it up so that it will sync every 2 minutes? It's critical for our operation to be as time synced as possible to other network servers –  Jonathan Nov 17 '11 at 17:35
    
I have iburst set in the configuration file, I also restarted the server and it's still ~30s away –  Jonathan Nov 17 '11 at 17:43
    
I've synced servers before and their time delta fell immediately to a few milliseconds. AFAIK remaining on 30 seconds this long means something's not working. Also, why would the ntp status give zeros on delays and jitters, that is never true –  Jonathan Nov 17 '11 at 17:49
    
by "stats" did you mean ntpq -p output? posted... –  Jonathan Nov 17 '11 at 18:22
    
I completely disabled the firewall, still no joy –  Jonathan Nov 17 '11 at 20:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.