Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got my IIS 7.5 running with the FTP role installed. When I right-click the site node in the IIS manager I don't see the option "Add FTP Site". What could be wrong here?

share|improve this question

migrated from stackoverflow.com Nov 17 '11 at 23:17

This question came from our site for professional and enthusiast programmers.

2 Answers 2

You need to install the FTP Role Service. You can do this by modifying the Application Server role in Server Manager.

share|improve this answer

Very likely you've not enabled this under your installed Windows components. Fixing this is very easy. Go to your control panel and find the "Programs" page.

Click on "Turn Windows Features On/Off" and look for Internet Information Systems. Expanding that tab will probably result in an unchecked box for "FTP Server". Just check the box, let it install and you are all set!

share|improve this answer
1  
2st problem I can see here - poster is setting up an FTP site. ;-) –  JasonC Nov 17 '11 at 23:28
1  
This answer is for Server 2003. MarkM is correct for Server 2008 R2. –  Driftpeasant Nov 17 '11 at 23:30
    
Hadn't realized this changed with 2008, sorry about that. Thank you to the the one who provided me with reputation points :) –  brpyne Nov 18 '11 at 0:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.