Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I couldn't connect to one Tomcat server via JMX in a Linux virtual machine.

There was no firewall running. All seemed ok. By searching on the web I found out that I have to use the -Djava.rmi.server.hostname property to fix it. It worked, but I don't understand why.

My machine has five Tomcat servers running, all of them have JMX enabled in consecutive ports (8008, 8018, 8028...), all of them have the same configuration and only one of them had this issue connecting JMX.

No firewall, no -Djava.rmi.server.hostname property in any Tomcat.

I understand the problem, but I don't understand why four of my Tomcat servers worked and one of them not. Why is this?

share|improve this question

migrated from superuser.com Nov 18 '11 at 12:12

This question came from our site for computer enthusiasts and power users.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.