Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

ok did a test to different hardware for a sbs 2003 r2 sp1 machine, client wants a documented test. Have done this in the past many times for others but this time the "preparing network connections" takes long, takes about 20 minutes to boot to the ctrl+alt+dlt

  • booting into safe mode is fast
  • booting into directory services mode is fast (seems when exchnage services and Active Directory are not involved things are good)

  • i did the restore using the backup from sbs 2003 under directory services mode

  • i restored the c drive and the system state
  • booted back in and fixed the nic on the system to same old ip address, same with dns and such everything is the way it should be.
  • rebooted, and ad comes up and all the forward and reverse lookups under internal dns are there too.
  • i made hidden items (old nics) under device manager come up and i removed them too.

normally at this stage i would be done and things would be quick to boot, the testing would be over. BUT i keep getting slow preparing network connections. I have done this with the nic connected by cable and with it removed. The main even id is 1126 about the global catalog error. i checked under sites and services and it seems to be enabled.

this used to be on a two DC network. the other DC is a server 2003 unit. Since it was SBS 2003 all the fsmo roles were moved to the sbs 2003 box 3 years ago. Also both DC's were made
GC (global catalogs)

THE DNS is pointing to itself. Do i have to do anything ms loopback adapter? never did in the past but if so is there any whitepapers on it. i was thinking maybe there is a chance that the loopback adapter is still locked to the old hardware.

what else can i do to test? thanks. gd

share|improve this question
    
in case anyone is wondering the loop back adapter is a good thing to enable on the original sbs 2003 server if you want to migrate to other hardware. you basically add the loopback adapter and set that to the static ip address of the nic. Then when you bring it back from restoring you will at least have the loop back with correct settnigs. You can then boot into the server without it timing out and make the proper changes back to the new nic on your new hardware. –  user8256 Jun 30 '09 at 3:18
    
actually what i meant to say is create the loopback adapter, make the static changes to the loopback adapter, then snapshot the server, then turn it off and migrate it. –  user8256 Jun 30 '09 at 3:19
add comment

2 Answers

up vote 0 down vote accepted

A variety of things could cause what you're seeing. Typically it is DNS-related, but it doesn't have to be, and it sounds like you checked that out already.

Toggle the "Verbose vs normal status messages" setting in the "System" section of group policy "Administrative Templates" to "Enabled" and see if the message "Preparing network connections..." changes to something a bit more helpful. (I set this setting to "Enabled" on all Customer networks. It's very handy to see more verbose information about what's happening during the time that WinLogon is putting the machine together.)

Could you edit your post to include a more detailed description about what you say you're seeing in the event log?

share|improve this answer
    
can't find Administrative Templates under the gpo for SBS 2003? –  user8256 Jun 30 '09 at 2:19
    
seems to stick at active directory is starting with verbose status message enabled. –  user8256 Jun 30 '09 at 3:08
    
if you can't get verbose status message to come up through group policy, in case someone is looking for an answer or alternate method, i added the follownig in regedit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System i added the dword of verbosestatus and gave it hex value 1 –  user8256 Jun 30 '09 at 3:09
    
i redid the restore and tested using a single sata drive, i was messing with cloning last night and ended up cloning a raid 1 test to a single sata so there might of been chipset or driver issues. Anyways with the new restore test machine i am down to exactly 6 minutes for a full ctrl+alt+dlt screen from the time i turn on the sbs box. I think this is pretty good, all services work including the clients exchange, active directory, internal dns integrated with active directory, a bunch of dongle application based license servers and sharepoint. So the restore is a success, it did speed up whe –  user8256 Jun 30 '09 at 3:12
    
it did speed up when i removed the other DC that is not here onsite from the Sites link in Active directory, i removed it and it's Global Catalog role. The error about trynig to contact GC is now gone. Funny thing is that the SBS box was always a GC but anyways it is working. –  user8256 Jun 30 '09 at 3:14
add comment

In safe mode, try setting the Microsoft Exchange Services to 'Manual' insted of 'Automatic' in services.msc. If the server boots OK have a look in the 'queue directory' ; by default this is in c:\program files\exchsrvr\mailroot\vsi 1\queue or check the 'messages' tab on the 'Default SMTP Virtual Server' in Exchange Manager for the location. If there are any files in the queue firectory move them to a different location, set the Exchange services back to Automatic and reboot.

I have seen this issue before where there is a corrupt message in the queue folder.

share|improve this answer
    
cheked and there is nothing in there.gd –  user8256 Jun 30 '09 at 2:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.