Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed SQL Server 2008 Express Edition R2. I'm trying to connect to the server (local) via the Management Studio, but it shows me the server is not available or the SQL server configuration is wrong. I went to the configuration, enabled the TCP/IP protocol in the Network configuration. I tried to enable a SQL server agent service, but I can't do it, because it shows me an error.

How can I connect to the server on my local computer?

share|improve this question

migrated from stackoverflow.com Nov 18 '11 at 15:03

This question came from our site for professional and enthusiast programmers.

    
Is the SQL Server Browser service enabled and started? –  mellamokb Nov 18 '11 at 14:57
    
Yes, I started it, but it doesn't make any difference –  daroPL Nov 18 '11 at 14:58
    
@JonEgerton I think Database Administrators SE (dba.stackexchange.com) is a better resource for this sort of question. –  Thomas Stringer Nov 18 '11 at 14:59
    
The SQL Agent service will not work for the express edition of SQL. It is installed but disabled. –  Jason Cumberland Nov 18 '11 at 17:51

1 Answer 1

Is the SQL Server service actually started? If it is not, you will be unable to connect. You won't need the SQL Server Agent service started to connect to the instance, but just out of curiousity what is the error you are receiving?

When you say you are local, are you trying to connect while being ON the server? The reason I ask is because if you are on the same machine, Shared Memory is the protocol that will be used. But if you are on a separate machine it is TCP/IP.

SQL Server Express installs as a named instance by default (SQLEXPRESS). You need to ensure that your SQL Browser service is started so that the dynamic port allocation and client notification can happen. That is most likely your issue. Start the SQL Server Browser service and retry to connect.

share|improve this answer
    
I started the SQL Server Browser service, but no difference. I use '(local)' as a server name. –  deem Nov 18 '11 at 15:06
1  
Try it with HOSTNAME\SQLEXPRESS (Where hostname is your real hostname) –  Dan Nov 18 '11 at 15:09
    
@Dan, yeah! Thank you! –  deem Nov 18 '11 at 15:18
    
@daroPL that got me years back, when I first started! I THINK (local)\SQLEXPRESS would work, too but I've never done that. –  Dan Nov 18 '11 at 15:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.