Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm installing gitolite on a Debian Squeeze box with the following preseed:

gitolite        gitolite/gituser        string  git
gitolite        gitolite/adminkey       string  ssh-rsa AAAAB3ECT
gitolite        gitolite/gitdir         string  /var/lib/git

On installation:

# debconf-set-selections /var/cache/debconf/gitolite.preseed
# apt-get install gitolite
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  git-daemon-run gitweb
The following NEW packages will be installed:
  gitolite
0 upgraded, 1 newly installed, 0 to remove and 26 not upgraded.
Need to get 0 B/114 kB of archives.
After this operation, 348 kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package gitolite.
(Reading database ... 24715 files and directories currently installed.)
Unpacking gitolite (from .../gitolite_1.5.4-2+squeeze1_all.deb) ...
Setting up gitolite (1.5.4-2+squeeze1) ...
adduser: The home dir must be an absolute path.
dpkg: error processing gitolite (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
 gitolite
E: Sub-process /usr/bin/dpkg returned an error code (1)

Why? The pre-seed was extracted from a manually configured installation, per here and exists without issue on another machine.

share|improve this question

1 Answer 1

The format for debconf-set-selections should be:

gitolite gitolite/gituser string  git

Note that I'm only using ONE whitespace as separator.

from the man of debconf-set-selections:

All other lines set the value of one question, and should contain four values, each separated by one character of whitespace.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.