Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Windows 2003 64 bit terminal server which we run a Java application from. The application has always worked up until 2 days ago. No new updates have been installed to the server in that time frame. I have tried re-installing java 64 bit but still have the following error.

Unexpected exception: java.lang.reflect.InvocationTargetException

java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.sun.javaws.Launcher.executeApplication(Unknown Source)
    at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
    at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
    at com.sun.javaws.Launcher.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
**Caused by: java.lang.UnsatisfiedLinkError: C:\Documents and Settings\administrator\Application Data\Sun\Java\Deployment\cache\6.0\19\625835d3-5826d302-n\swt-win32-3116.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform**
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(Unknown Source)
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)
    at java.lang.System.loadLibrary(Unknown Source)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:100)
    at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
    at org.eclipse.swt.graphics.Device.init(Device.java:563)
    at org.eclipse.swt.widgets.Display.init(Display.java:1784)
    at org.eclipse.swt.graphics.Device.<init>(Device.java:99)
    at org.eclipse.swt.widgets.Display.<init>(Display.java:363)
    at org.eclipse.swt.widgets.Display.<init>(Display.java:359)
    at com.ko.StartKO.main(StartKO.java:57)
    ... 9 more
share|improve this question

2 Answers 2

As per the comment on the other answer,

The issue was fixed by uninstalling 64 and 32-bit Java and then only re-installing 32-bit Java.

(Moving user101425's comment to an answer as he seems unlikely to return)

share|improve this answer

"Can't load IA 32-bit .dll on a AMD 64-bit platform"

Something's changed.

Try:

  • clearing the cache
  • locating the 64-bit version of that DLL
  • Restoring from backups to see what's changed
share|improve this answer
    
I ended up fixing the issue by uninstalling Java 32 bit and 64 bit and then just re-installing Java 32 bit. Thanks for the help. –  user101425 Nov 18 '11 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.