Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Setting up a new 64 bit RHEL 6 server with ext4 FS. Have only worked with ext3 and 32bit RHEL5 before. No matter what I try, I cannot get it to work.

Current settings for mount (from "mount" command):

/dev/sda7 on / type ext4 (rw,noatime)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,noexec,nosuid)
/dev/sdb1 on /backup type ext4 (rw)
/dev/sda1 on /boot type ext4 (rw,noatime)
/dev/sda8 on /home type ext4 (rw,noatime,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0)
/dev/sda2 on /tmp type ext4 (rw,noexec,noatime)
/dev/sda6 on /usr type ext4 (rw,noatime)
/dev/sda5 on /var type ext4 (rw,noatime,usrjquota=aquota.user,jqfmt=vfsv0)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

Essentially trying to get user/group quotas on /home, and user quotas on /var. Created the aquota.user and aquota.group files on /home and /var:

-rw-r--r-- 1 root root 0 Nov 17 13:37 /home/aquota.group
-rw-r--r-- 1 root root 0 Nov 17 13:37 /home/aquota.user
-rw------- 1 root root 0 Nov 17 11:43 /var/aquota.user

When I run quoatcheck I get:

quotacheck -vguma

quotacheck: WARNING -  Quotafile /home/aquota.user was probably truncated. Cannot save quota settings...
quotacheck: WARNING -  Quotafile /home/aquota.group was probably truncated. Cannot save quota settings...
quotacheck: WARNING -  Quotafile /var/aquota.user was probably truncated. Cannot save quota settings...

Then I attempt quotaon and get:

quotaon -av

quotaon: Cannot find quota file on /home [/dev/sda8] to turn quotas on/off.
quotaon: Cannot find quota file on /home [/dev/sda8] to turn quotas on/off.
quotaon: Cannot find quota file on /var [/dev/sda5] to turn quotas on/off.

quota rpms installed:

rpm -qa|grep -i quota

quota-3.17-16.el6.x86_64
quota-devel-3.17-16.el6.x86_64

Any ideas what I'm doing wrong or what I should adjust to get quotas to work as they do in ext3/32bit?

share|improve this question

1 Answer 1

Figured it out. Had to first delete the aquota.* files. Seems jquota does not like them existing, even as 0 byte files, like normal quota set ups.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.