Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Problem

We are running VMware Server 2.0.0 build-116503 on a Ubuntu 10.04 LTS server. There is a virtual machine installed, running Lotus Domino on Windows Server 2003.

Ever since a sudden power failure last week, the virtual machine won't properly start up. When I run the command:

vmrun -T server -h https://127.0.0.1:8333/sdk -u root -p jk2x2208 start "[standard] lotus/test.vmx"

… after 30 seconds it displays:

Error: Unknown error

That's about everything I get. I know the command is right, since that's what we've used all the time.

This has happened last Saturday after a scheduled backup shutdown, and somehow I was able to start it again. This week, it happened again, and I can't get it back up.

Occasionally, I also get:

Error: Cannot connect to the virtual machine

When I get this, and I run the start command, it seemingly works.

Another thing I've been trying is this:

root@mail01:~# vmrun -T server -h https://127.0.0.1:8333/sdk -u root -p pass start "[standard] lotus/test.vmx"
Error: Unknown error
root@mail01:~# vmrun -T server -h https://127.0.0.1:8333/sdk -u root -p pass start "[standard] lotus/test.vmx"
root@mail01:~# rm /etc/vmware/not_configured 
root@mail01:~# vmrun -T server -h https://127.0.0.1:8333/sdk -u root -p pass start "[standard] lotus/test.vmx"
root@mail01:~# ping server
PING server (192.168.1.200) 56(84) bytes of data.

Why is this so random? Which configuration could have been messed up?


What I've tried / other info

  • I already shut down VMware itself with /etc/init.d/vmware stop. This works.

  • I tried to start VMware again with /etc/init.d/vmware start. It complains that it's "not configured", which is why I had to rm /etc/vmware/not_configured, and then try to start again.

  • There have been no software updates on the machine, and no configuration changes

share|improve this question
    
have you checked the logs? what clue they give about this problem? –  Farhan Nov 27 '11 at 11:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.