Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have computer with Ubuntu behind router that I can't configure. However I want to have ssh access to that computer. I think it is possible with ssh tunneling, but I don't know how to do it. I have another server to which I would like to setup tunneling. How to do it? Or maybe you have some other idea how to solve this problem?

I tried:

ssh -N user@my_server -L 22/localhost/8090

but it says:

bind: Address already in use
channel_setup_fwd_listener: cannot listen to port: 22
Could not request local forwarding.
share|improve this question

2 Answers 2

up vote 16 down vote accepted

You are asking it to listen on your local port 22 and forward connections to a remote system's port 8090. You can't do that as your local port 22 is already taken by your local SSH server.

I think what you are looking for is remote forwarding. Replacing -L 22:localhost:8090 with -R 8090:localhost:22 will tell the remote host to listen on port 8090 and forward requests to your SSH server.

If you are leaving the connection running so you can get in later from a remote site, then you are going to want to make sure the connection doesn't time-out due to inactivity by adding the relevant options (-o TCPKeepAlive=yes or -o ServerAliveInterval=30)

So you'll end up with something like:

ssh -N user@my_server -R 8090:localhost:22 -o ServerAliveInterval=30

Also, if one of the network hops between you and the server is down at any point, the connection will drop despite any KeepAlive options you specify, so you might want to add this command to inittab, or look into the daemontools package or your distro's equivalent , so that it always starts on boot and is restarted when it exits for some reason other then system shutdown (or you could run it from a shell script that loops infinitely, but init or daemontools are cleaner solutions).

share|improve this answer
    
It almost works. I can connect to my computer, but I can do it only when I'm logged on server. I would like to connect via that port from everywhere. –  klew Jun 29 '09 at 17:59
2  
If you add the server's public address or a wild-card to the port forwarding definition (-R 111.222.333.444:8090:localhost:22 or -R *:8090:localhost:22) then that may work, though that sort of thing can be disabled on the server. If the server is one you control, then ensure that the GatewayPorts option is enabled in sshd_config. –  David Spillett Jun 29 '09 at 21:06
    
Thanks for help, it work! –  klew Jun 29 '09 at 21:51
    
I wrote a script that helps me to do ssh tunneling, you can check it out at: github.com/gdbtek/ssh-tunneling –  Nam Nguyen Apr 27 at 9:43

The reason you can't do this is because you're trying to forward port 22 on the local computer to port 8090 on the remote server and something is already running on port 22 on the local server. Mostly likely you have an SSH server running. You can fix this by changing the 22 to a different value. You can check to see if a port is free by running:

# netstat -lep --tcp

This lists all the listening sockets, so if the port isn't listed, then it's free.

share|improve this answer
    
Thanks for your answer ! –  klew Jun 29 '09 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.