Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently using Xen PV on CentOS 5 with my domU's as flat files running on a hardware RAID controlled (write cache enabled) formatted with XFS. On the dom0 I can get about 500MB/s in a 2GB dd write from /dev/zero however on the domU's I'm lucky if I get 10MB/s (it is usually around half that).

I've tried changing the disk scheduling to NOOP on the domU's, changed some mount parameters and tweaked the performance allocations of both the dom0 (prioritize CPU) and domU's (increase RAM and VCPU allocations). None of these steps have produced any noticeable change in performance.

My instinct here is that it is not a hardware problem, due to the solid performance of the dom0. Any ideas on what might be causing this problem? I'm considering moving to LVM based domU's.

share|improve this question
    
To be precise, you added elevator=noop to the domU's boot command line? What effect did that have? What kernel version in the domU's? What CPU? Also, see Xen best practices for a list of issues and how to work around them. –  David Schwartz Nov 20 '11 at 7:38
    
Correct, I added elevator=noop to the kernel boot options on the domU's. There was no noticeable change. AMD Opteron Processor 246 HE. I have visited the Xen Best Practices page and followed the tips there. –  user98651 Nov 20 '11 at 7:40

1 Answer 1

up vote 1 down vote accepted

It's well known that using a file as a block device for a Xen domU is going to cause poor performance; do try an LVM LV or straight block device.

Also depending on how much write cache your RAID controller has, 2GB isn't that big and may just be testing the speed of cache in the dom0.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.