Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got several Ubuntu 10.04 virtual machines running as Hyper-V guests on Windows Server 2008 R2 SP1 and they're all perfectly fine.

Today I installed my first Ubuntu 11.10 virtual machine and I'm seeing rediculous pings:

enter image description here

These servers are all connected via gigabit to a local LAN, with almost no network traffic at all1, with a legacy network adapter in Hyper-V.

I'm a bit of an Ubuntu n00b so I don't really know where to go from here. Any ideas?


free -m reports:

             total       used       free     shared    buffers     cached
Mem:           485        470         15          0         63        299
-/+ buffers/cache:        107        378
Swap:          507         20        487

This is within a few mb of our other Ubuntu servers that are on 10.04.


I removed the Legacy NIC and installed a Synthetic one in Hyper-V and this did improve the numbers, in that they're around 10-30ms now, but I would still be expecting <1ms response times.

1As a comparison, I have another Ubuntu 10.04 guest on Hyper-V almost 1,000km away that has a ping of 33ms

share|improve this question
    
Have you verified that pings to the physical machine are not being lost as well, to ensure networking issues aren't present, or tried pinging directly from the host machine to one of the virtual machines? –  Conspicuous Compiler Nov 20 '11 at 22:54
    
@ConspicuousCompiler - yep, pings to the physical host are correct (<1ms) –  Mark Henderson Nov 20 '11 at 22:57
    
What does free -m on the virtual system report? –  Conspicuous Compiler Nov 21 '11 at 0:00
    
@ConspicuousCompiler - updated question –  Mark Henderson Nov 21 '11 at 0:04
    
Updated the latest 11.10 kernel? Any differences in integration components between your 10.04 builds and 11.10? –  evilensky Nov 21 '11 at 0:24

4 Answers 4

up vote 3 down vote accepted

Since it's a new system, it may have needed to download and install quite a few updated packages. If the slowness is still present, try doing something like

ps -ef|grep apt

on the virtual machine to see if there's an apt-related process running. If the slowness suddenly resolved itself, it's worth checking /var/log/dpkg.log to see if a bunch of packages were installed, causing the slowness.

share|improve this answer

Are hv_netvsc, hv_blkvsc, hv_storvsc and hv_vmbus kernel modules loaded on the guest? I run Ubuntu 10.04 under Hyper-V and ping is under 1ms. You can check modules using sudo lsmod | grep hv command.

share|improve this answer
    
Yep, all loaded. The problem has just gone away on its own in the last hour or so after doing absolutally nothing to it (I went out to lunch and came back). –  Mark Henderson Nov 21 '11 at 2:02

This problem has gone away on its own. Sorry I don't have a better answer than that.

I realise this is like pushing the green button but as this is not a mission critical production machine, I'm going to count my blessings and move on.

For what it's worth, switching to a synthentic NIC rather than a legacy NIC made a huge difference, but did not alleviate the problem completely.

share|improve this answer
1  
Shot in the dark, but check /var/log/dpkg.log on the new system. Maybe apt had to update a whole bunch of packages, and the downloading/installing was affecting response time. –  Conspicuous Compiler Nov 21 '11 at 4:21
    
@ConspicuousCompiler - and you win a gold star. There's hundreds of entries in that log that all end at about the time I went to lunch. Post that as an answer and I'll give it the checkmark. –  Mark Henderson Nov 21 '11 at 4:25
    
Done. Glad the mystery was solved. –  Conspicuous Compiler Nov 21 '11 at 6:11

Old thread but still a reply; make sure after installing you remove the nic and then add a 'synthetic NIC' within Hyper-V. Ubuntu has the correct drivers for it and as far as I know it will use paravirtualization that way. Also on Windows guests OS'es you'll really want the synthetic NIC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.