Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're seeing a strange situation, where some executables won't run from a Windows command prompt (running as admin).

Just running the command (say, filename.exe) gives no response on the console. No errors, no output, nothing.

If we copy over the same Windows .exe from a different folder, it "magically" starts working, and we see the default console output.

(Happens both on Win7 x64, and Win2008R2 x64. Application is running as 32-bit process.)

At the time when it accesses the .exe, I can see events in the application and system logs regarding Windows-Security-SPP, and it makes me believe that the .exe is being blocked from execution.

Does this sound familiar?

share|improve this question
add comment

1 Answer 1

No, SPP is Software Protection Platform and is a service that is related to Windows activation and licensing. It has nothing to do with application restrictions.

It's possible that this is caused by a Software Restrictions GPO, which is capable of blocking an exe by name, path, or hash. If you run gpresult /H, you will be able to see this policy and modify it accordingly if it's the culprit.

share|improve this answer
    
Thanks, I've checked the gpresult report, and no rules had been created. Only thing, my DC is Windows 2008 x86, but the servers are either Win7 x64 or Win2008 R2 x64. Not sure if that would cause any problem in the domain policy management. I'm going to test a similar situation in a VM that doesn't live in a domain. –  Kirk Marple Nov 22 '11 at 20:04
    
@KirkMarple That won't cause any issues that you're seeing. x86 2008 will happily manage any architecture of supported clients. –  MDMarra Nov 22 '11 at 20:05
    
Looking into this more, there's another .exe in the same folder that works fine. Both .exe's show the same VC++ runtime DLL imports. The developer of both apps says they're built the same, and from the same build process. Still stumped as to why the one .exe won't even load, until we overwrite the .exe with the same file from another folder. Only doing that seems to unblock it. –  Kirk Marple Nov 25 '11 at 5:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.