Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting very bad write speeds with ntfs

sudo mount -t ntfs -o sync,noatime,gid=users /dev/sdf1 "/media/MNTPNT"

testing with DD

dd if=/dev/zero of=/media/6ED8C60456B3EBDA/test.tmp bs=1k count=128k

2585+0 records in
2585+0 records out
2647040 bytes (2.6 MB) copied, 22.6904 s, 117 kB/s

This is to a 1tb WD Passport, I also have a 500gb WD Passport formatted with ext4 which (last logged run of rsync) averaged writes at 15MB/s

sudo cat /dev/sdb | pv -r > /dev/null

Gave read speeds ~40MB/s

Linux 3.0.0-12-server 21/11/11 _x86_64_ (2 CPU)

share|improve this question
Have you tried different block sizes instead of 1k? Perhaps 4k maybe? – Zoredache Nov 21 '11 at 3:45
What is the physical interface? USB? – Andrew Nov 21 '11 at 4:08
bs=4k did boost write to 1.5MB/s, yes interface is USB, will test the ext4 drive again to see max write – Thermionix Nov 21 '11 at 6:18

Try bs=32k, bs=64k, or even bs=1M: USB has significant turnaround time - and you use sync mount option. That kills write speed as it disables the write cache.

share|improve this answer
interesting, removed sync & noatime and now writing at ~40MB/s with bs=4k. rsync averaged ~26MB/s – Thermionix Nov 21 '11 at 8:51

I think the problem was with sync option, the default is to mount everything with async. Synchronous operations take more time than asynchronous by definition. So, you can put back noatime and actually you can get some performance gain from it but I am not sure if noatime has any effect on ntfs-3g.

share|improve this answer

Try to put the parameter *big_writes* into your mount command:

sudo mount -t ntfs -o async,big_writes,noatime,gid=users /dev/sdf1 "/media/MNTPNT"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.