Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I uninstalled MAMP completely, downloaded fresh copy of MAMP 2 from the MAMP website, did a clean install. However, when I try to start mysql, I get the following error log

111120 21:37:49 mysqld_safe Starting mysqld daemon with databases from 

/Applications/MAMP/db/mysql
111120 21:37:50 [Warning] You have forced lower_case_table_names to 0 through a command-line option, even though your file system '/Applications/MAMP/db/mysql/' is case insensitive.  This means that you can corrupt a MyISAM table by accessing it with different cases. You should consider changing lower_case_table_names to 1 or 2
111120 21:37:50 [Note] Plugin 'FEDERATED' is disabled.
111120 21:37:50 InnoDB: The InnoDB memory heap is disabled
111120 21:37:50 InnoDB: Mutexes and rw_locks use GCC atomic builtins
111120 21:37:50 InnoDB: Compressed tables use zlib 1.2.3
111120 21:37:50 InnoDB: Initializing buffer pool, size = 128.0M
111120 21:37:50 InnoDB: Completed initialization of buffer pool
111120 21:37:50 InnoDB: highest supported file format is Barracuda.
111120 21:37:50  InnoDB: Waiting for the background threads to start
111120 21:37:51 InnoDB: 1.1.5 started; log sequence number 1595675
111120 21:37:51 [ERROR] /Applications/MAMP/Library/bin/mysqld: unknown option '--skip-locking'
111120 21:37:51 [ERROR] Aborting

111120 21:37:51  InnoDB: Starting shutdown...
111120 21:37:51  InnoDB: Shutdown completed; log sequence number 1595675
111120 21:37:51 [Note] /Applications/MAMP/Library/bin/mysqld: Shutdown complete

111120 21:37:51 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended

I've no clue why this is happening. I googled around and made sure that no instance of MySQL is running. Nothing seems to help.

share|improve this question

1 Answer 1

check your /etc/my.cnf, or try to rename it to /etc/my.cnf.old. or you can check on your /etc/my.cnf is there any options --skip-locking ?, just remove it. and try to restart mysql again

share|improve this answer
    
After dozens of "stop other mysqld processes" responses across the web, thank you for this! Still can't figure out why MAMP would be using this buried OS config file, but this fixed my problem. –  Stephen R Nov 24 '13 at 3:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.