Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This can sound a little bit paranoid but I really have a doubt that my configured libvirt+kvm uses any hardware acceleration in debian. I setuped it with this guide. in fact i've checked already, kvm-intel module is loaded for sure. But inside vm with freebsd for example, I have such a huge lag while, for example: installing OS, extracting port tree with csup, and of course compiling ports also. Resources are pretty big on that machine: 4 cores of cpu and 4gb of ram. I can confirm that I had same setup with proxmox on debian, before setuping libvirt manually on the same machine. So I do know how fast guest must be. So it's really out of question about hardware issue, I mean OVH hosting states that: Intel Core i5-2400 4x3.1+ GHz 6 Mb L2 - QPI 5 GT/sec is ued and virtualisation is: VT Instructions

So as I said this setup worked before. The only thing that, maybe, I missed kernel module configuration, but kvm-intel is loaded, and my friend checked that libvirt uses it too. so please tell me what I did wrong , maybe guide giving wrong steps..? maybe freebsd guest doesn't support something? if you need some additional information please write in comments. Maybe it's worth to mention that I've updated kernel, since new installation of debian was done (on host). Maybe loaded module can't find something related to kernel.. anyway I'm really puzzled what to do next.

this configuration was used to create vm:

# virt-install --connect qemu:///system -n bsd -r 4096 --vcpus=2 --disk path=/home/vm/hdd/bsd.img,size=100 -c /home/vm/iso/FreeBSD-8.2-RELEASE-amd64-disc1.iso --vnc --noautoconsole --os-type unix --os-variant freebsd7 --accelerate --network=bridge:br0,mac=02:00:00:a7:66:32 --hvm

Update: ps -ef | grep qemu

106       2370     1  5 09:40 ?        00:24:10 /usr/bin/kvm -S -M pc-0.12 -enable-kvm -m 4095 -smp 2,sockets=2,cores=1,threads=1 -name roman -uuid 405855d7-7fbe-7ecb-d125-b23fd9c9d07a -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/roman.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=utc -boot c -drive file=/home/vm/hdd/roman.img,if=none,id=drive-ide0-0-0,boot=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -device ne2k_pci,vlan=0,id=net0,mac=02:00:00:a7:66:31,bus=pci.0,addr=0x3 -net tap,fd=32,vlan=0,name=hostnet0 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -vnc 127.0.0.1:0 -k en-us -vga cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x4
share|improve this question
    
when the VM is running, can you post the output of ps -ef |grep qemu on the host? –  dyasny Nov 21 '11 at 10:06
    
updated the topic –  holms Nov 21 '11 at 16:16

2 Answers 2

up vote 0 down vote accepted

-enable-kvm in the cmd line means VT you're not in emulation mode. However, I also see -M pc-0.12 there, I'm not really sure how this can affect performance. -M means the emulated machine type, and this was probably set so, because you specified BSD as the guest OS. I would try to build a VM for RHEL6 (for example), then install FBSD there, and see if there are changes in performance.

looking further, you have your first disk working as ide (which is much slower than virtio) and the netdev is ne2k, which is also much slower than virtio. Not sure there are FBSD drivers for virtio_net or virtio_blk, but it's worth a quick google search

share|improve this answer

You can invoke "info kvm" in the qemu monitor (Ctrl + Alt + 2 in the Qemu window, or you can start qemu with -monitor stdio)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.