Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an e-commerce site with 300,000 products and 20,000 categories. It is slow and currently in production. I decided to install Varnish to speed up. The trouble is that during installation, I got a Guru Meditation.

Since the site is in production, I am not allowed to leave this error more than a second, thinking to have made an enormous stupidity.

I followed the following tutorial: http://www.euperia.com/linux/setting-up-varnish-with-apache-tutorial

I'm sure I followed all without error.

I say that there may be a specific configuration with plesk.

Has anyone already installed Varnish on a ubuntu 11.04 server with plesk 10? Does anyone have a better resource?

I know it is "very vague" as an error, but maybe some of you have had this problem.

edit 24/11/2011

I continued to work on Varnish + Plesk ... but it still does not work.

1) I changed the port for apache in plesk General

# mysql -uadmin -p`cat /etc/psa/.psa.shadow` -D psa -e'replace into misc (param, val) values ("http_port", 8008)'

1.1) I rebuild the server conf

# /usr/local/psa/admin/bin/httpdmng --reconfigure-all

2) I changed the apache conf files (if those were not taking full plesk top)

vim /etc/apache2/ports.conf

NameVirtualHost *:8008
Listen 8008

2.1) I do the same with /etc/apache2/sites-enables/000-default

3) I changed the port of my vhost (a single server)

vim /var/www/vhosts/MYDOMAIN.COM/conf/XXXXXXXXX.http.include

Replace the port 80 by this I want.

Rebuild the vhost conf

/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=<domain_name> 

with without www

(See my issue in serverfault: Edit vhost port in plesk 10.3 )

4) I installed varnish by following this tutorial : http://www.euperia.com/linux/setting-up-varnish-with-apache-tutorial

5) I restart apache 2 + varnish

service apache2 restart
service varnish restart

When I go to my site, I come across a page of apache

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

Can somebody help me ?

This means that my vhost does not point to the right place. Why? What to do? How?

share|improve this question
    
I continued to work on Varnish + Plesk ... but it still does not work. 1) I changed the port for apache in plesk General # mysql -uadmin -p`cat /etc/psa/.psa.shadow` -D psa -e'replace into misc (param, val) values ("http_port", 8008)' 1.1) I rebuild the server conf # /usr/local/psa/admin/bin/httpdmng --reconfigure-all 2) I changed the apache conf files (if those were not taking full plesk top) vim /etc/apache2/ports.conf NameVirtualHost *:8008 Listen 8008 2.1) I do the same with /etc/apache2/sites-enables/000-default 3) I changed the port of my vhost (a single server) vim /var/www/vhosts/MYD –  Raphaël Nov 23 '11 at 14:50
    
Does apache work if you connect to it directly on the 8008 port? Can you test varnish on a seperate IP? What are the backend settings in varnish? Does testing those with telnet work? What does varnish log when it's shows the error? –  arjarj Nov 23 '11 at 15:56
    
thank for answer. If y go on mysite:8008 -> "it works but blabla". My server has one ip. So I can test only on this site with his particular config. I don't find the varnish log... it's for that I'm totally desperate –  Raphaël Nov 23 '11 at 16:18
add comment

1 Answer

up vote 0 down vote accepted

I decided to go through a third party company to handle this specific configuration. They are partners in Plesk and it seems to be too complicated for a novice like me.

Thank you to those who read and commented.

Bye

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.