Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to move the SVN backup files from the local directory to a NAS device via Putty and I am using the following syntax, however I am receiving the below error message -

debian@debianvm:~/svn-backups$ smbclient //IP/Volume_1/NAS/SVN_backups/ -U 'username' 'password'
Domain=[DLINK-88F0C6] OS=[Unix] Server=[Samba 3.2.8]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

Could you please let me know what might be the root cause?

share|improve this question
add comment

1 Answer

You must provide a share name to smbclient; a subdirectory is not supported.

smbclient //IP/Volume_1 -U username password

You should be able to verify this by mounting the share somewhere:

mount -t cifs //IP/volume_1 /mnt/tmp -o user=username,pass=password

share|improve this answer
    
Giving a password on the command line is considered bad practice for security resaons: unprivileged users could potentially read the password from the output of ps or by checking the relevant parts of the /proc filesystem. In the case of smbclient you can use the -A/--authentication-file option instead, if mounting filesystems use the credentials mount option. –  David Spillett Nov 21 '11 at 16:05
    
And ? THat's what he did - I merely assist in troubleshooting. –  adaptr Nov 21 '11 at 16:42
    
Thanks m8, I managed :) –  Chris Cutajar Nov 22 '11 at 10:04
    
@adaptr: just adding potentially relevant information, I wasn't suggesting your answer was wrong. I nearly added the comment to the question instead but felt it made more sense here as the question didn't mention mount and you has added that (useful) detail. –  David Spillett Nov 22 '11 at 10:33
    
I can mount a subdirectory (on Debian squeeze) using mount -t cifs '\\cifs.cs.brown.edu\home\jon-test' /mnt/ -o user=jon-test without problems. Also, @DavidSpillett , it conveniently asks me for my password without additional options :) –  jon Dec 16 '11 at 19:14
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.