Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're using the Small Business Server Backup that comes with SBS 2008 to backup all drives to an iomega iSCSI-Target. The Backup works fine and everything is shown as successfully backed up.

But the exchange-logs in C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group and C:\Program Files\Microsoft\Exchange Server\Mailbox\Second Storage Group aren't flushed.

What could cause this behaviour?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

When you look at the backup configuration, is the box to backup the Exchange Information Store checked, or are you only backing up the drives?

share|improve this answer
    
SBS Backup doesn't give me that option in SBS Console. I can only select the drives to backup, the backup-target and the timeplan. –  wullxz Nov 21 '11 at 23:08
    
That would be why - unless your backup agent is Exchange aware (that is, it knows it's backing up an Exchange database), it treats the database as a file and does not commit the logs. –  Driftpeasant Nov 21 '11 at 23:15
    
But the integrated SBS 2008 Backup should be able to backup the exchange-database, shouldn't it? I mean: Microsoft ships this backup-tool with an SBS that has ALWAYS an exchange-server on board... –  wullxz Nov 21 '11 at 23:17
    
Right - and your exchange database is being backed up. It's just not aware enough to commit the logs. It is an included tool, but it's not a full featured one. –  Driftpeasant Nov 21 '11 at 23:52
    
<irony>Great!</irony>... So, what should I do to get the logs commited? Is there any recomended way to do this? –  wullxz Nov 21 '11 at 23:59
show 2 more comments

Here is a link that can do what you need on Win2k8 R2, I know you are referring to SBS however not sure how many features are included for 'Window Server Backup' within SBS.

In summary: Windows server backup->Backup schedule->Modify Backup->Custom->Add items + Advanced Settings=>Vss Settings=>VSS FULL BACKUP->Backup Time->Destination Type->Keep or Change Backup Destination->Finish [Verify that in advance option you see VSS full backup]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.