Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OS: Win Server 2008 RC2 Windows firewall on (no effect when off)

I have suddenly been plagued by an issue in which I cannot find any similar ones with a search.

I am running about 20 game servers that bind to a UDP port, then bind to a TCP port 1 above the UDP port. Suddenly, a day ago, new TCP binds stopped functioning.

Now, I have confirmed that other applications cannot listen on most ports. For example, I have a java program that I made a copy of, and tried the following ports: 33001, 23789, 89... completely random ports.

As far as the applications already that have TCP bindings, such as HTTP and MySQL, only port 8080 was one port I discovered could work, and only for Apache. If applications would leave their default port they could not bind, however they returned to normal when the port was default.

I've checked for listening applications through netstat and curports, also checked for any connections on these ports, and they're completely free.

share|improve this question
add comment

migrated from stackoverflow.com Nov 22 '11 at 0:57

This question came from our site for professional and enthusiast programmers.

2 Answers

Perhaps you had your program listed in the firewall's exception list, and the list got wiped out.

I've also run into a situation where there were two firewalls installed, and you needed to configure them both properly. That caused some pulled hair.

share|improve this answer
    
I just happened to notice something. The listening TCP ports I have right now can only be accessed from localhost. I cannot remotely access any TCP ports (excluding RDP). This is equivalent to a program binding to an incorrect address, except that this applies to all my TCP services. –  Kalphiter Nov 21 '11 at 23:58
    
I completely retract the above (turned off firewall), however the real problem still remains at hand, the fact that I can't make any new programs listen. –  Kalphiter Nov 22 '11 at 0:03
add comment

Have you tried starting the Windows Firewall service, then starting / stopping it from the Windows Firewall interface?

Click start, click search; search for "Windows Firewall with Advanced Security"

Windows 7 and 2008R2 has the issue where the background service must be started, regardless of what you want to do with the firewall.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.