Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Everything was working just fine until i rebooted my server and now when I visit the page (with both apache and mysql running), I get the following:

Oops! Google Chrome could not connect to mydomain.com

Apache is confirmed to be running, as is MySQL.

The /var/log/httpd/error_log looks as follows:

[Tue Nov 22 10:06:05 2011] [notice] caught SIGTERM, shutting down
[Tue Nov 22 10:06:05 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Nov 22 10:06:05 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 22 10:06:05 2011] [notice] Digest: done
[Tue Nov 22 10:06:05 2011] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations

I believe the caught SIGTERM, shutting down is when i performed service httpd restart

Again -- server, apache, and MySQL are up and running, only using 7% of disk space, but I cannot get it to serve any pages. I haven't touched the httpd.conf file any time recently so I'm not sure what is going on.

Also, apache restarts just fine given its config file. The configuration points to the correct directory as well.

Any ideas?

share|improve this question
    
Can you access the server locally? It can be a network problem. Also, make sure the server is listening on the port 80 by using netstat -lnp. –  Khaled Nov 22 '11 at 10:22
    
Yes, check my answer -- i had an issue with firewalls blocking. I disabled them but I'm not sure of the proper solution to keep the firewalls up but allow access to :80 –  Atticus Nov 22 '11 at 10:23
add comment

1 Answer

Ah -- i had firewalls blocking my port

iptables -F has cleared the problem, but I am assuming is definitely not a proper fix.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.