Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Cpanel related to exim mail server.

I want to refuse any email from sender which has attachment size over 15 MB.

How can i do this?

share|improve this question

migrated from stackoverflow.com Nov 22 '11 at 11:06

This question came from our site for professional and enthusiast programmers.

2 Answers 2

  • Go to WHM -> Main -> Service Configuration -> Exim Configuration Editor
  • At the bottom, click on "Advanced Editor"
  • put the line : message_size_limit = 15M on the first text box
  • Click on save.

Message size limit not actually limits attachment(s) only size, but...

share|improve this answer
    
Are you sure? This parameter is a Postfix parameter and not an Exim one. –  mailq Nov 22 '11 at 22:58
    
@mailq, Exim too. exim.org/exim-html-current/doc/html/spec_html/ch14.html –  Zoredache Nov 23 '11 at 3:46
    
thanks for help ^_^ message_size_limit = 15M Its work fine –  eldorado Nov 23 '11 at 9:56

You should add

message_size_limit = 15M

to the exim.conf. And This line can be added below this line:

message_body_visible = 5000 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.