Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I don't face this problem while working on localhost only when I access the page using the IP address of my system this happens and it only happens with IE (works on all other browsers).

By the way I'm using Tomcat V6.0.0.29, IE8

I tried debugging the JS code using IE developer tools debugger, of course when I open using http://localhost:8080/ everything works perfectly fine, but when I use http://myIP:8080/ this loop is giving a problem.

$('#someId > div').each(function(){...}); 

As in this loop doesn't run at all, it just kind of skips it. I have checked the IDs they are fine moreover it's working in localhost why should it give a problem when I access it using my IP?

I also tried using Apache 2.2 with Tomcat as container but it gives the same problem.

share|improve this question
    
this question was also posted in stackoverflow follow the link to view the discussion there stackoverflow.com/questions/8223584/… –  pranky64 Nov 22 '11 at 12:06
add comment

2 Answers

Please check your .js calling html command.

 <script type="text/javascript" src="http://localhost:PORT/a.js">

Please change it to

  <script type="text/javascript" src="http://YOURIP:PORT/a.js">

Also IE have same problem on font defination.

share|improve this answer
    
I'm not using absolute paths, i'm using relative paths! and the js and jquery are loaded because i can see them in the IE debugger!! –  pranky64 Nov 22 '11 at 12:13
add comment

I guess this question wasn't really meant for serverfault it was a problem with IE7 any way here is the answer Check out the answer here!!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.