Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I rent a CentOS 5 VPS from a UK-based provider, with DirectAdmin also installed. On Thursday night, they carried out planned maintenance to changed the two IPs I had been assigned to two new ones. On Friday, after the change had taken place, I updated my domain name records to reflect the IP change.

Since then, all of the domains pointing to the VPS are timing out. Additionally, DirectAdmin was also not responding, but was was resolved by running the ipswap scripts as found in the DirectAdmin knowledgebase. It did not fix my domains though. I have contacted the VPS provider but I have been waiting for a response for some time now.

I have checked again, and again, and all the IPs referenced in DirectAdmin are correct. If I go to the server IP in my browser it responds with "Apache is functioning normally." Email accounts on the server are also functioning correctly.

But if I access a domain itself, it times out. Running a ping and a DNS look-up, I can confirm the nameserver IPs are correct. If I run a trace route it reaches an IP that is similar to my VPS IPs (last 2 blocks are different) before timing out (it never shows my server IP).

I am relatively new to VPS management so don't have a vast wealth of experience with troubleshooting problems on them. I have checked all of the httpd configuration files, which don't seem to have any IP references in them at all. Looking in the Apache error logs, what errors there are do not coincide with times I have tried to access the site.

Is this issue at my provider's end? Is there anything else I can check or test, to rule out post-IP-change problems with my server configuration? It was all running fine prior to the IP change.

share|improve this question
    
what is the output from netstat -tulpn and service iptables status? –  Bart De Vos Nov 22 '11 at 16:57

1 Answer 1

up vote 1 down vote accepted

Have you tried flushing your DNS cache? In windows (as an administrator) try ipconfig /flushdns and see if the problem persists. DNS has a process, called Time-To-Live, which dictates for how long a DNS entry should remain cached at a remote server. Many servers do not honor the TTL and will keep the old entry in their cache for as long as their servers are online.

You can test this by using the "nslookup" command to test against multiple DNS servers, for instance: nslookup mydomain.com 8.8.8.8 will check what your domain name resolves as to google's dns server. Try this approach on other nameservers and see if the entry is correct. If it is, then it's probably a caching issue with the DNS server you're using.

share|improve this answer
    
Doh, it really was that simple. It was one of the first things I tried this morning but it seems I was still ahead of it propagating to the DNS I tried. Switched to the Google DNS servers and it worked straight away (which explains why the email worked - I use Gmail to retrieve them). Thanks for answering what now seems like quite a daft question. –  Fourjays Nov 22 '11 at 21:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.