Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to add command-line support for PHP5 on my server. When I run aptitude install php5-cli I get a message saying that my PHP modules/packages have unmet dependencies.

Here is a list of packages that suffer from these "unmet dependencies" and needs and upgrade:

  • php5-gd
  • php5-curl
  • php5-mysql
  • php5-cgi

They all depend on php5-common.

Can I upgrade the packages just like aptitude suggests without causing any disruptions to the live site?

Output from aptitude

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initialising package states... Done
The following packages are BROKEN:
  libapache2-mod-php5 php5-cgi php5-curl php5-gd php5-mysql 
The following NEW packages will be installed:
  php5-cli 
The following packages will be upgraded:
  php5-common 
1 packages upgraded, 1 newly installed, 0 to remove and 123 not upgraded.
Need to get 3,511kB of archives. After unpacking 7,803kB will be used.
The following packages have unmet dependencies:
  php5-gd: Depends: php5-common (= 5.3.3-1ubuntu12~lucid) but 5.3.5-1ubuntu7.2ppa1~lucid is to be installed.
  php5-curl: Depends: php5-common (= 5.3.3-1ubuntu12~lucid) but 5.3.5-1ubuntu7.2ppa1~lucid is to be installed.
  php5-mysql: Depends: php5-common (= 5.3.3-1ubuntu12~lucid) but 5.3.5-1ubuntu7.2ppa1~lucid is to be installed.
  php5-cgi: Depends: php5-common (= 5.3.3-1ubuntu12~lucid) but 5.3.5-1ubuntu7.2ppa1~lucid is to be installed.
  libapache2-mod-php5: Depends: php5-common (= 5.3.3-1ubuntu12~lucid) but 5.3.5-1ubuntu7.2ppa1~lucid is to be installed.
The following actions will resolve these dependencies:

Upgrade the following packages:
libapache2-mod-php5 [5.3.3-1ubuntu12~lucid (now) -> 5.3.5-1ubuntu7.2ppa1~lucid (lucid)]
php5-cgi [5.3.3-1ubuntu12~lucid (now) -> 5.3.5-1ubuntu7.2ppa1~lucid (lucid)]
php5-curl [5.3.3-1ubuntu12~lucid (now) -> 5.3.5-1ubuntu7.2ppa1~lucid (lucid)]
php5-gd [5.3.3-1ubuntu12~lucid (now) -> 5.3.5-1ubuntu7.2ppa1~lucid (lucid)]
php5-mysql [5.3.3-1ubuntu12~lucid (now) -> 5.3.5-1ubuntu7.2ppa1~lucid (lucid)]

Score is 340
share|improve this question

2 Answers 2

up vote 2 down vote accepted

My answer is maybe! ;-)

PHP 5.3.3 to 5.3.5 shouldn't matter. That is, unless Ubuntu/Debian did something extra crazy. But point releases (e.g. 5.3.x to 5.3.y) should never break a feature set.

That is to say, that hopefully you didn't do crazy hacks and e.g. relied on bugs in 5.3.3 which were fixed in 5.3.5 and therefor would cause a regression. The easiest way to test this is to spin up a test VM and see if your site works (or even better: your test suite runs).

Another trick is to try to install 5.3.3 – here's an idea (note my version is different):

# apt-cache showpkg php5-cli
Package: php5-cli
Versions: 
5.2.10.dfsg.1-2ubuntu6.10
...

(I truncated the output.)

Then install with:

# apt-get install php5-cli=5.2.10.dfsg.1-2ubuntu6.10
...

HTH

share|improve this answer

You're using Nginx PPA and Aptitude tries to update packages for newer versions. If you want to install php5-cli from Ubuntu repository you must use aptitude install php5-cli=5.3.3-1ubuntu12~lucid.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.