Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Got a question about hosting a website at GoDaddy and using Google Apps to handle mail for a single domain.

1) I use registrar's name servers so that I can change DNS settings.

2) I changed the A record to point to the IP address where I want to host my website and change www CNAME to mydomain.com

3) I changed MX records to what Google's instructions said.

The website shows up fine, but something funny is going on with e-mail. For some reason Mac mail cannot send to user@mydomain.com. I get:

Verify that you have addressed this message correctly. Check your SMTP server settings in Mail preferences and verify any advanced settings with your system administrator.

Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be sent.

When I try to send e-mail to other addresses it works fine, so I suspect something is wrong with the A record pointing one place and MX records pointing to Google.

Any ideas why this is happening?

share|improve this question

migrated from stackoverflow.com Nov 22 '11 at 19:56

This question came from our site for professional and enthusiast programmers.

closed as off topic by RobM, Scott Pack, crb, MDMarra, voretaq7 Dec 7 '11 at 21:19

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Hmmm... this may actually belong on SuperUser. –  SLaks Nov 22 '11 at 19:58
    
This should work fine; I'm doing it myself on 4 different domains. Do you have a CNAME for the naked domain? –  SLaks Nov 22 '11 at 20:19
    
Ah, no I don't. I have cname for www (host) CNAME mydomain.com but godaddy won't let me leave the host field blank. What do I place in there? –  user1060524 Nov 22 '11 at 20:26
    
An A record. CNAMEs on the naked domain break some mail servers. –  SLaks Nov 22 '11 at 20:27
    
I see. So in addition to @ (host) ipaddress, I also add an @ (host) mydomain.com as an A record... actually, it won't let me add a non-ip address. –  user1060524 Nov 22 '11 at 20:29
show 6 more comments

1 Answer 1

Sometimes it takes time for the records to propagate properly through the internet and have a valid route. If they do not work after 24-48 hours, then you have a problem and should contact Google Apps support.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.