Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have CentOS running vsftpd but I am unable to connect using loccl users (local_enable=YES). If I set anonymous_enable=YES then it works just fine, but when I enter my user name and password (I don't want to allow anonymous connections) then all I see is 'Cannot display the webpage' error.

I'm no Linux expert, but as far as I can tell the username/password combination that I am using is fine and the user is allowed by vsftpd.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It seems to me that the browser or the FTP client you are using is not sending the username/password to the FTP server.

If you using a browser-like URL, try to use one of these forms:

ftp://user@ftpserver/url-path
ftp://user:password@ftpserver/url-path
share|improve this answer
    
Thanks for the reply. Both of those take me to the same 'Cannot display the webpage' error. I've tried in an FTP client now as well, and logging in as 'root' yeilds the error 'Access denied'. I have userlist_enabled=YES in vsftpd.conf and 'root' is listed in /etc/vsftpd/user_list. Is there something that I am missing? –  David Gard Nov 23 '11 at 10:35
    
Ok, so I've figured out to change to userlist_enabled=NO, so the username and password is being accepted, but now I'm getting the error 500 OOPS: Cannot change directory: {directory from chroot_list}. That directory is set to 777, so everyone should be able to change it. –  David Gard Nov 23 '11 at 11:08
    
Setting directory mode to 777 may not be enough if its parent can not be accessed. –  Khaled Nov 23 '11 at 11:31
    
Got it - there was an erronious 's' at the end of one of the files. All connected to FTP now, just a couple of small issues that I can hopefully fix! Thanks for your advice. –  David Gard Nov 23 '11 at 12:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.