Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm investigating an issue, which is described almost perfectly here:

http://support.citrix.com/article/CTX122238

I've followed the steps in Part 2 and confirmed that the WMI service does not have the correct permissions that Citrix requires.

My question: How do I change this? The MMC snap-in is read-only and I'm not entirely sure what I'm looking at.

Citrix just say:

If this is not present you must check Microsoft Group Policies to see what is being applied to this server. Change Group Policy to include rights to LOCAL SERVICE.

Which is not very helpful.

It's a Server 2003 R2 box on a very small 2003 domain. It does have GPO's applied, but I can't find any configuration relating to this and I know for a fact it's not a part of our standard rollout because otherwise I'd know about it!

share|improve this question
    
While this is no longer an issue, I'd be interested in any resolution. –  Dan Nov 30 '11 at 13:24

1 Answer 1

up vote 1 down vote accepted

You may either create a new GPO to deploy this setting, or add this configuration to an existing GPO containing related settings.

Open gpmc.msc and create/edit the GPO which will apply this policy. Drill down:

  • Computer Configuration > Windows Settings > Security Settings > System Services

In the right pane, locate "Windows Management Instrumentation". Double click, or right-click and choose "Properties".

enter image description here

A new window will appear. Check "Define this policy", select your required startup mode, "Automatic" in this case, then click "Edit Security".

enter image description here

The familiar "Security" window appears. Click "Add".

enter image description here

In the selection window, click "Locations".

enter image description here

Choose the local machine at the top. If your domain is selected instead, you'll receive a "User not found" error when entering the user name.

enter image description here

Enter LOCAL SERVICE in the "Enter the object names to select" field. Click "OK"

enter image description here

LOCAL SERVICE will now be listed in the "Security" tab. Check the required permission(s) for this service, "Read" and "Start, Stop, Pause" in this example. Click "OK"

enter image description here

"OK" on the remaining open window and you'll be back to the Group Policy Management Editor. Exit the editor and link the GPO as required.

share|improve this answer
    
Thanks! I'll take a look at this tomorrow and see if it did the trick –  Dan Feb 29 '12 at 16:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.