Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I've just installed Icinga and Icinga-Web. And everything looked ok when first inspecting the UI's on http://[server]/icinga/ and http://[server]/icinga-web/...

I went on and added some new hosts, services, commands, etc. and reloaded the icinga service, without problems. Then I flushed the icinga-web cache and restarted the apache2 service, again no problems.

After reloading the configuration, all of the new hosts and services shows up just fine, in the old icinga UI, and the checks are running perfectly, well almost ;) (see below).

Old Icinga UI Status

However, in the new icinga-web interface it's a completely different story. The icinga-web UI still shows the hosts from the initial configuration (a single 'localhost' host with 8 services). The UI also shows the 'default' instance as being 'down' in the header status, and that 'the data is X minutes old' (see below).

New Icinga-Web UI Status

I've tried retracing my steps, by re-reading the icinga-web installation guide, but I can't figure out what I've done wrong or how to correct it. I've also tried to fiddle with the access.xml and databases.xml configuration files.

What am I doing wrong and how do I fix it?

share|improve this question
Which Version of Icinga do you use? Build from source? What about icinga-web? Recent (1.6.0?) Did you check the rights of your user? – shakalandy Dec 12 '11 at 21:56
I'm using icinga 1.5.1 with icinga-web 1.5.2. But I have fixed the problem. Turned out it was some service not running. – JohannesH Dec 13 '11 at 7:14
JohannesH, I realize it was quite a while ago that you dealt with this, but do you remember what service was not running? I'm having the same trouble. – bshacklett Oct 19 '12 at 13:17
I believe it was the database service. – JohannesH Oct 21 '12 at 0:30
up vote 5 down vote accepted

In my case, there were two changes that needed to be made.

1) /etc/default/icinga needs to be configured so that IDO2DB will run:

# start ido2db daemon (no/yes)

2) The IDO module needs to be defined in /etc/icinga/modules/


define module {
    module_name    ido_mod
    path           /usr/lib/icinga/
    module_type    neb
    args           config_file=/etc/icinga/idomod.cfg

The previous config file will, of course, need to match how your system is configured. The above is being used on an Ubuntu 12.10 server.

share|improve this answer
thanks. installed icinga using this tut and i was missing these instructions to get it to work – ufk Sep 15 '13 at 11:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.