Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up VSFTPD passive hosting on my EC2 instance. I ran through these instructions http://www.synergycode.com/knowledgebase/blog/item/ftp-server-on-amazon-ec2 . However, when I tried to connect in FileZilla, I got

  • Command: CWD /home/lingiii/ftp
  • Response: 250 Directory successfully changed.
  • Command: TYPE I
  • Response: 200 Switching to Binary mode
  • Command: PASV
  • Response: 227 Entering Passive Mode (10,222,206,33,54,184).
  • Status: Server sent passive reply with unroutable address. Using server address instead.
  • Command: LIST
  • Error: Connection timed out
  • Error: Failed to retrieve directory listing

Where directory /home/lingiii/ftp is set to wrx permissions for user lingiii, group developers (of which lingiii is a member) AND I'm logging in as user lingiii.

Any advice?

share|improve this question
2  
It looks like you haven't set the pasv_address to the public IP (i.e. it used 10.222.206.33 as the address - which is an private address - implying either the wrong address was used or the value wasn't set). See if you can fix that, as it appears to be a communication problem between your client and server. –  cyberx86 Nov 24 '11 at 1:44
    
Are there any updates to this question? –  barfoon Mar 13 '12 at 21:28

1 Answer 1

As @cyberx86 said, vsftpd is sending the instance's internal IP address as the address the client must connect to in response to the PASV command, which the client can't connect to since it isn't running inside EC2. You need to use the pasv_address configuration option to tell vsftpd what the public IP of the instance is.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.