Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Ubuntu setup with 3 network interface and I also have a HP Procurve switch with port 1 configured as a mirroring port.

However, eth0 does not connect when I plug a cable to port 1. When I plug to port 2 or port 3, Ubuntu is able to connect and grab IP from the DHCP server.

Is there something wrong here?

share|improve this question
    
How did you check that the eth0 is not connected when connected the mirror port? –  migabi Nov 24 '11 at 9:58
    
Hi migabi, Ubuntu will state that eth0 is connected through a prompt on the right. –  James D. White Nov 24 '11 at 14:11

1 Answer 1

Try a setting up a different port than 1 as mirror. And try wether you can connect to port 1 in normal mode. If that doesn't work, port 1 may be damaged.

Also check the Procurve's manual about the implications of setting up a port as mirror port (While unlikely; does it disable autonegotiation by chance?).

Try forcing both the client and switch to a specific (same!) speed/duplex mode. If it works now, you had a b0rked (read mismatching) autonegotiation setting on one of those two. (Usually, speed and duplex mode should be configured to be set up by autonegotiation).

(There is also the slight possibilty that you need to use a crossover cable, but since most interfaces today do Auto-MDIX, I state this merely for the sake of completeness).

share|improve this answer
    
Hi Roman, thanks for your reply. I have tried assigning port 5 as a mirror port but it still does not work. I have also tried manually configuring the speed / duplex mode as well as using a crossover cable but none of it work. –  James D. White Nov 24 '11 at 14:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.