Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed awstats recently using these commands:

yum install awstats
cd /usr/share/awstats/tools/
/usr/bin/perl awstats_configure.pl
    -> /etc/httpd/conf/httpd.conf
    -> www.ysend.com
    -> /etc/awstats
/usr/share/awstats/tools/awstats_updateall.pl now
mkdir /home/cron
nano /home/cron/www.ysend.com.cron
    -> 10 * 1 * * /usr/share/awstats/tools/awstats_updateall.pl now
crontab /home/cron/www.ysend.com.cron
crontab -l
nano /etc/httpd/conf.d/awstats.conf
    -> Allow from **MY IP**
/etc/init.d/httpd restart

However, when I visit my Awstats page, it only displays 1 unique visitor. I've had hundreds of unique visitors. Any idea about what's going on?

If I try to run awstats_updateall.pl, it says:

From data in log file "/var/log/httpd/access_log"...

How can I tell it to point to /home/ysend/custom.log?

share|improve this question
    
Here is my virtual host setup: <VirtualHost *:80> ServerName www.ysend.com ServerAlias ysend.com ServerAdmin john@kurlak.com DocumentRoot /home/ysend/public_html CustomLog /home/ysend/custom.log common ErrorLog /home/ysend/error.log </VirtualHost> –  John Jun 29 '09 at 20:09

1 Answer 1

up vote 1 down vote accepted

It's been a while since I set up awstats, but I'm pretty sure there's a directive in the CONF file that you point to your log location. Be warned if a custom CONF file uses an included main CONF file (like I set up for my servers) because the option could be set in an included file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.