Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get Munin to report quota usage but it's not working. On top of quota_usage_ it says:

# Usage: place in /etc/munin/node.d/quota-usage_<dev> (or link it there using
# ln -s), for example quota-usage_hda3. Use underscores instead of slashes, for
# example to monitor /dev/mapper/vol-foo, name this quota-usage_mapper_vol-foo

So I did just that but it doesn't seem to work.

munin-node.log says:

2011/11/25-11:05:08 [23728] Error output from quota_usage_:
2011/11/25-11:05:08 [23728]     Can't exec "/etc/munin/plugins/quota_usage_": No such file or directory at /usr/share/perl5/Munin/Node/Service.pm line 215, <STDIN> line 87.
2011/11/25-11:05:08 [23728]     # ERROR: Failed to exec.
2011/11/25-11:05:08 [23728] Service 'quota_usage_' exited with status 42/0.

Any ideas what I'm doing wrong? I'm running Debian 6 in case it matters. I have it symlinked as quota-usage_xvda (it's running on a Xen VPS) and repquota /dev/xvda runs just fine.

Update - got it working by putting it into /etc/munin/plugins/ and setting it to run as root (as Dom suggested) but I now get this in munin-graph.log:

2011/11/25 18:15:10 [RRD ERROR] Unable to graph /var/cache/munin/www/xxx/xxx/quota_usage_xvda-week.png : opening '/var/lib/munin/--g.rrd': No such file or directory

After some research it looks like that's a bug: http://munin-monitoring.org/ticket/794

Editing as the diff shows fixes it but I only get 2 users reported in the graphs now instead of the roughly dozen I have. Oh well...

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Try to run quota-usage_xvda. If it works, you have to add the root user in your munin-node.conf for this plugin. You can then check by munin-run quota-usage_xvda. Check if your repquota is in /usr/sbin/ directory (as it is hard coded in the plugin). Are you sure that the link is good ? The quota_usage_ should be outside of /etc/munin/plugins dir

share|improve this answer
    
The instructions in the plugin say to place it into /etc/munin/node.d/ which is what I did but it did not run from there. I put it into /etc/munin/plugins/ (where I had it originally when I had that error) but it looks like when I tried it first I forgot to set it to run as root so it didn't work. Setting it to run as root and from inside /etc/munin/plugins/ works now but it errors out on graphs now... Any idea why that could be? I put the error in the original question. –  pixelDanny Nov 25 '11 at 18:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.