Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have three servers, Server X, Y, and Z.
I have the main mysql DB on X (innodb DB).
now I have created Master-Slave from X to Y. everything is working fine here.
and now i set Y as a master for Z.
when i do show slave status on Z (the third server)

show slave status\G
Slave_IO_State: Waiting for master to send event
...
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
...
Seconds_Behind_Master: 0

but the data is not synchronized and nothing has been moved from Y to Z. any idea about what might cause this??
EDIT
in my.cnf on server Y, i have the following conf:

log-slave-updates=ON
log-bin=mysql-bin

but in show variables like '%slave%' i have

show variables like '%slave%';
+---------------------------+--------+
| Variable_name             | Value  |
+---------------------------+--------+
| init_slave                |        |
| log_slave_updates         | OFF    |
| slave_compressed_protocol | OFF    |
| slave_exec_mode           | STRICT |
| slave_load_tmpdir         | /tmp   |
| slave_net_timeout         | 3600   |
| slave_skip_errors         | OFF    |
| slave_transaction_retries | 10     |
| sql_slave_skip_counter    |        |
+---------------------------+--------+

Thanks for your help

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Make sure that you have started Y with --log-slave-updates option so that update received from X are logged by Y to its binary log.


in my.cnf on server Y, i have the following conf:

log-slave-updates=ON

Use the boolean value instead of switch value:

log-slave-updates=true

The results:

mysql> show global variables like '%slave%';
+---------------------------+--------+
| Variable_name             | Value  |
+---------------------------+--------+
| init_slave                |        |
| log_slave_updates         | ON     |
| slave_compressed_protocol | OFF    |
| slave_exec_mode           | STRICT |
| slave_load_tmpdir         | /tmp   |
| slave_net_timeout         | 3600   |
| slave_skip_errors         | OFF    |
| slave_transaction_retries | 10     |
| sql_slave_skip_counter    |        |
+---------------------------+--------+
9 rows in set (0.00 sec)
share|improve this answer
    
i have edited my question... please advise –  Alaa Alomari Nov 25 '11 at 21:42
    
It means that you haven't restarted MySQL after changing my.cnf file. –  quanta Nov 26 '11 at 2:27
    
sure i did many times... it is old configuration... however i just did it again and have the samething!! :( –  Alaa Alomari Nov 26 '11 at 3:39
    
updated my answer. –  quanta Nov 26 '11 at 3:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.