Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an apache installation on my dev machine. The httpd.conf is all set up right. By the config file I should be getting an access.log file in my logs directory, but it doesn't seem to exist in the directory.

However if I search for the file in AgentRansack it shows the file as existing and being some 400K in size. I am running Windows 7 with Apache started manually as a process not a service.

I have:

  • Set explorer to show system and hidden files
  • Tried to open from AgentRansack directly but I get an error, or a blank file.
  • Tried Shutting down apache to see if the files appear.

Why cant I access my access.log file? Is this a know issue.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I would suggest that if you have Apache installed to %programfiles% the problem lies with the way Windows handles files created by programs in the %programfiles% directory. In Vista and Windows 7, virtualization is used to save files to the VirtualStore directory (%username%\AppData\Local\VirtualStore) when a program saves them to %programfiles%. This is relatively transparent to the program (Apache in this case), which means that monitoring its file access, shows that it is reading and writing from %programfiles%. (I once used SysInternals Process Monitor to try and track down my missing files - without any success - the only thing that worked was a full drive search).

Navigate to the correct path under VirtualStore (matching the path in Program Files) and you may find your missing file.

More information about VirtualStore is available on Microsoft's site.

share|improve this answer
    
thanks for the suggestion, I'll check it out. You are correct its installed in program files (the default). –  Toby Allen Nov 27 '11 at 8:28
    
Spot on Thanks. –  Toby Allen Nov 27 '11 at 16:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.